summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2023-07-06 17:51:37 +0200
committerGuilherme Amadio <amadio@gentoo.org>2023-07-06 18:11:40 +0200
commit443b60a7c73a5637dad6a47a50b5351163572818 (patch)
treeb127513925678b226bcf824ce6d5e5d2d1328dae /dev-util/perf/files
parentprofiles: Mask dev-perl/Gtk2-Notify for removal (diff)
downloadgentoo-443b60a7c73a5637dad6a47a50b5351163572818.tar.gz
gentoo-443b60a7c73a5637dad6a47a50b5351163572818.tar.bz2
gentoo-443b60a7c73a5637dad6a47a50b5351163572818.zip
dev-util/perf: drop 5.19-r1, 6.0-r1, 6.2-r1
Closes: https://bugs.gentoo.org/832704 Closes: https://bugs.gentoo.org/855539 Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'dev-util/perf/files')
-rw-r--r--dev-util/perf/files/perf-5.18-clang.patch45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-util/perf/files/perf-5.18-clang.patch b/dev-util/perf/files/perf-5.18-clang.patch
deleted file mode 100644
index d1c9a48e6848..000000000000
--- a/dev-util/perf/files/perf-5.18-clang.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-
-Fix building against LLVM/Clang with monolithic libraries.
-
---- a/tools/build/feature/Makefile
-+++ b/tools/build/feature/Makefile
-@@ -299,7 +299,7 @@ $(OUTPUT)test-llvm.bin:
- $(BUILDXX) -std=gnu++14 \
- -I$(shell $(LLVM_CONFIG) --includedir) \
- -L$(shell $(LLVM_CONFIG) --libdir) \
-- $(shell $(LLVM_CONFIG) --libs Core BPF) \
-+ $(shell $(LLVM_CONFIG) --libs) \
- $(shell $(LLVM_CONFIG) --system-libs) \
- > $(@:.bin=.make.output) 2>&1
-
-@@ -312,10 +312,7 @@ $(OUTPUT)test-clang.bin:
- $(BUILDXX) -std=gnu++14 \
- -I$(shell $(LLVM_CONFIG) --includedir) \
- -L$(shell $(LLVM_CONFIG) --libdir) \
-- -Wl,--start-group -lclangBasic -lclangDriver \
-- -lclangFrontend -lclangEdit -lclangLex \
-- -lclangAST -Wl,--end-group \
-- $(shell $(LLVM_CONFIG) --libs Core option) \
-+ -lclang-cpp $(shell $(LLVM_CONFIG) --libs) \
- $(shell $(LLVM_CONFIG) --system-libs) \
- > $(@:.bin=.make.output) 2>&1
-
---- a/tools/perf/Makefile.perf
-+++ b/tools/perf/Makefile.perf
-@@ -417,14 +417,11 @@ EXTLIBS := $(call filter-out,$(EXCLUDE_EXTLIBS),$(EXTLIBS))
- LIBS = -Wl,--whole-archive $(PERFLIBS) $(EXTRA_PERFLIBS) -Wl,--no-whole-archive -Wl,--start-group $(EXTLIBS) -Wl,--end-group
-
- ifeq ($(USE_CLANG), 1)
-- CLANGLIBS_LIST = AST Basic CodeGen Driver Frontend Lex Tooling Edit Sema Analysis Parse Serialization
-- CLANGLIBS_NOEXT_LIST = $(foreach l,$(CLANGLIBS_LIST),$(shell $(LLVM_CONFIG) --libdir)/libclang$(l))
-- LIBCLANG = $(foreach l,$(CLANGLIBS_NOEXT_LIST),$(wildcard $(l).a $(l).so))
-- LIBS += -Wl,--start-group $(LIBCLANG) -Wl,--end-group
-+ LIBS += -lclang-cpp
- endif
-
- ifeq ($(USE_LLVM), 1)
-- LIBLLVM = $(shell $(LLVM_CONFIG) --libs all) $(shell $(LLVM_CONFIG) --system-libs)
-+ LIBLLVM = $(shell $(LLVM_CONFIG) --libs) $(shell $(LLVM_CONFIG) --system-libs)
- LIBS += -L$(shell $(LLVM_CONFIG) --libdir) $(LIBLLVM)
- endif
-