summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIgor V. Kovalenko <igor.v.kovalenko@gmail.com>2022-12-24 17:33:57 +0300
committerSam James <sam@gentoo.org>2022-12-27 10:21:45 +0000
commit5718e87e3541bf83c9f8864a0a7e4fa230255eb3 (patch)
treec6de8d1a446f91301cf4c01701a65ce4be49eab9 /dev-util/lttng-modules/lttng-modules-2.13.7.ebuild
parentdev-python/pefile: remove dependency to dev-python/future (diff)
downloadgentoo-5718e87e3541bf83c9f8864a0a7e4fa230255eb3.tar.gz
gentoo-5718e87e3541bf83c9f8864a0a7e4fa230255eb3.tar.bz2
gentoo-5718e87e3541bf83c9f8864a0a7e4fa230255eb3.zip
dev-util/lttng-modules: add 2.13.7
Closes: https://bugs.gentoo.org/852305 Signed-off-by: Igor V. Kovalenko <igor.v.kovalenko@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28783 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/lttng-modules/lttng-modules-2.13.7.ebuild')
-rw-r--r--dev-util/lttng-modules/lttng-modules-2.13.7.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/lttng-modules/lttng-modules-2.13.7.ebuild b/dev-util/lttng-modules/lttng-modules-2.13.7.ebuild
new file mode 100644
index 000000000000..de25ec1df638
--- /dev/null
+++ b/dev-util/lttng-modules/lttng-modules-2.13.7.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod
+
+MY_P="${P/_rc/-rc}"
+MY_SLOT="$(ver_cut 1-2)"
+
+DESCRIPTION="LTTng Kernel Tracer Modules"
+HOMEPAGE="https://lttng.org"
+SRC_URI="https://lttng.org/files/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/${MY_SLOT}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BUILD_TARGETS="default"
+
+CONFIG_CHECK="MODULES KALLSYMS HIGH_RES_TIMERS TRACEPOINTS
+ ~HAVE_SYSCALL_TRACEPOINTS ~PERF_EVENTS ~EVENT_TRACING ~KPROBES KRETPROBES"
+
+MODULE_NAMES="true"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 3 0; then
+ eerror "${PN} require Linux kernel >= 3.0"
+ die "Please update your kernel!"
+ fi
+}
+
+src_compile() {
+ BUILD_FIXES="KERNELDIR=$KERNEL_DIR" linux-mod_src_compile
+}
+
+src_install() {
+ for i in $(find "${S}" -name "*.ko" -print); do
+ local val=${i##${S}/}
+ local modules+="${val%%.ko}(misc:) "
+ done
+ MODULE_NAMES=${modules}
+
+ linux-mod_src_install
+ dodoc ChangeLog README.md
+}