summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/lockrun
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/lockrun')
-rw-r--r--dev-util/lockrun/files/lockrun.c-20120508294
-rw-r--r--dev-util/lockrun/lockrun-20120508.ebuild31
-rw-r--r--dev-util/lockrun/metadata.xml7
3 files changed, 332 insertions, 0 deletions
diff --git a/dev-util/lockrun/files/lockrun.c-20120508 b/dev-util/lockrun/files/lockrun.c-20120508
new file mode 100644
index 000000000000..0b0034d7bc25
--- /dev/null
+++ b/dev-util/lockrun/files/lockrun.c-20120508
@@ -0,0 +1,294 @@
+/*
+ * $Id$
+ *
+ * written by : Stephen J. Friedl
+ * Software Consultant
+ * steve@unixwiz.net
+ * http://www.unixwiz.net/tools/
+ *
+ * ===================================================================
+ * ======== This software is in the public domain, and can be ========
+ * ======== used by anybody for any purpose ========
+ * ===================================================================
+ *
+ * Lockrun: This program is used to launch a program out with a lockout
+ * so that only one can run at a time. It's mainly intended for use out
+ * of cron so that our five-minute running jobs which run long don't get
+ * walked on. We find this a *lot* with Cacti jobs which just get hung
+ * up: it's better to miss a polling period than to stack them up and
+ * slow each other down.
+ *
+ * So we use a file which is used for locking: this program attempts to
+ * lock the file, and if the lock exists, we have to either exit with
+ * an error, or wait for it to release.
+ *
+ * lockrun --lockfile=FILE -- my command here
+ *
+ * COMMAND LINE
+ * ------------
+ *
+ * --lockfile=F
+ *
+ * Specify the name of a file which is used for locking. The file is
+ * created if necessary (with mode 0666), and no I/O of any kind is
+ * done. The file is never removed.
+ *
+ * --maxtime=N
+ *
+ * The script being controlled should run for no more than <N> seconds,
+ * and if it's beyond that time, we should report it to the standard
+ * error (which probably gets routed to the user via cron's email).
+ *
+ * --wait
+ *
+ * When a lock is hit, we normally exit with error, but --wait causes
+ * it to loop until the lock is released.
+ *
+ * --verbose
+ *
+ * Show a bit more runtime debugging.
+ *
+ * --quiet
+ *
+ * Don't show "run is locked" error if things are busy; keeps cron from
+ * overwhelming you with messages if lockrun overlap is not uncommon.
+ *
+ * --
+ *
+ * Mark the end of the options: the command to run follows.
+ *
+ */
+
+#include <stdio.h>
+#include <stdarg.h>
+#include <errno.h>
+#include <stdlib.h>
+#include <string.h>
+#include <fcntl.h>
+#include <unistd.h>
+#include <time.h>
+#include <sys/types.h>
+#include <sys/wait.h>
+#include <sys/file.h>
+
+#ifndef __GNUC__
+# define __attribute__(x) /* nothing */
+#endif
+
+
+#define STRMATCH(a,b) (strcmp((a),(b)) == 0)
+
+#define UNUSED_PARAMETER(v) ((void)(v))
+
+#define TRUE 1
+#define FALSE 0
+
+static const char *lockfile = 0;
+static int wait_for_lock = FALSE;
+static mode_t openmode = 0666;
+static int sleeptime = 10; /* seconds */
+static int Verbose = FALSE;
+static int Maxtime = 0;
+static int Quiet = FALSE;
+
+static char *getarg(char *opt, char ***pargv);
+
+static void die(const char *format, ...)
+ __attribute__((noreturn))
+ __attribute__((format(printf, 1, 2)));
+
+#ifdef __sun
+# define WAIT_AND_LOCK(fd) lockf(fd, F_TLOCK,0)
+#else
+# define WAIT_AND_LOCK(fd) flock(fd, LOCK_EX | LOCK_NB)
+#endif
+
+int main(int argc, char **argv)
+{
+ char *Argv0 = *argv;
+ int rc;
+ int lfd;
+ pid_t childpid;
+ time_t starttime;
+
+ UNUSED_PARAMETER(argc);
+
+ time(&starttime);
+
+ for ( argv++ ; *argv ; argv++ )
+ {
+ char *arg = *argv;
+ char *opt = strchr(arg, '=');
+
+ /* the -- token marks the end of the list */
+
+ if ( strcmp(*argv, "--") == 0 )
+ {
+ argv++;
+ break;
+ }
+
+ if (opt) *opt++ = '\0'; /* pick off the =VALUE part */
+
+ if ( STRMATCH(arg, "-L") || STRMATCH(arg, "--lockfile"))
+ {
+ lockfile = getarg(opt, &argv);
+ }
+
+ else if ( STRMATCH(arg, "-W") || STRMATCH(arg, "--wait"))
+ {
+ wait_for_lock = TRUE;
+ }
+
+ else if ( STRMATCH(arg, "-S") || STRMATCH(arg, "--sleep"))
+ {
+ sleeptime = atoi(getarg(opt, &argv));
+ }
+
+ else if ( STRMATCH(arg, "-T") || STRMATCH(arg, "--maxtime"))
+ {
+ Maxtime = atoi(getarg(opt, &argv));
+ }
+
+ else if ( STRMATCH(arg, "-V") || STRMATCH(arg, "--verbose"))
+ {
+ Verbose++;
+ }
+
+ else if ( STRMATCH(arg, "-q") || STRMATCH(arg, "--quiet"))
+ {
+ Quiet = TRUE;
+ }
+
+ else
+ {
+ die("ERROR: \"%s\" is an invalid cmdline param", arg);
+ }
+ }
+
+ /*----------------------------------------------------------------
+ * SANITY CHECKING
+ *
+ * Make sure that we have all the parameters we require
+ */
+ if (*argv == 0)
+ die("ERROR: missing command to %s (must follow \"--\" marker) ", Argv0);
+
+ if (lockfile == 0)
+ die("ERROR: missing --lockfile=F parameter");
+
+ /*----------------------------------------------------------------
+ * Open or create the lockfile, then try to acquire the lock. If
+ * the lock is acquired immediately (==0), then we're done, but
+ * if the lock is not available, we have to wait for it.
+ *
+ * We can either loop trying for the lock (for --wait), or exit
+ * with error.
+ */
+
+ if ( (lfd = open(lockfile, O_RDWR|O_CREAT, openmode)) < 0)
+ die("ERROR: cannot open(%s) [err=%s]", lockfile, strerror(errno));
+
+ while ( WAIT_AND_LOCK(lfd) != 0 )
+ {
+ if ( ! wait_for_lock )
+ {
+ if ( Quiet)
+ exit(EXIT_SUCCESS);
+ else
+ die("ERROR: cannot launch %s - run is locked", argv[0]);
+ }
+
+ /* waiting */
+ if ( Verbose ) printf("(locked: sleeping %d secs)\n", sleeptime);
+
+ sleep(sleeptime);
+ }
+
+ fflush(stdout);
+
+ /* run the child */
+
+
+ if ( (childpid = fork()) == 0 )
+ {
+ close(lfd); // don't need the lock file
+
+ execvp(argv[0], argv);
+ }
+ else if ( childpid > 0 )
+ {
+ time_t endtime;
+ pid_t pid;
+
+ if ( Verbose )
+ printf("Waiting for process %ld\n", (long) childpid);
+
+ pid = waitpid(childpid, &rc, 0);
+
+ time(&endtime);
+
+ endtime -= starttime;
+
+ if ( Verbose || (Maxtime > 0 && endtime > Maxtime) )
+ printf("pid %d exited with status %d (time=%ld sec)\n", pid, rc, endtime);
+ }
+ else
+ {
+ die("ERROR: cannot fork [%s]", strerror(errno));
+ }
+
+ exit(rc);
+}
+
+
+/*! \fn static char *getarg(char *opt, char ***pargv)
+ * \brief A function to parse calling parameters
+ *
+ * This is a helper for the main arg-processing loop: we work with
+ * options which are either of the form "-X=FOO" or "-X FOO"; we
+ * want an easy way to handle either one.
+ *
+ * The idea is that if the parameter has an = sign, we use the rest
+ * of that same argv[X] string, otherwise we have to get the *next*
+ * argv[X] string. But it's an error if an option-requiring param
+ * is at the end of the list with no argument to follow.
+ *
+ * The option name could be of the form "-C" or "--conf", but we
+ * grab it from the existing argv[] so we can report it well.
+ *
+ * \return character pointer to the argument
+ *
+ */
+static char *getarg(char *opt, char ***pargv)
+{
+ const char *const optname = **pargv;
+
+ /* option already set? */
+ if (opt) return opt;
+
+ /* advance to next argv[] and try that one */
+ if ((opt = *++(*pargv)) == 0)
+ die("ERROR: option %s requires a parameter", optname);
+
+ return opt;
+}
+
+/*
+ * die()
+ *
+ * Given a printf-style argument list, format it to the standard error,
+ * append a newline, then exit with error status.
+ */
+
+static void die(const char *format, ...)
+{
+va_list args;
+
+ va_start(args, format);
+ vfprintf(stderr, format, args);
+ putc('\n', stderr);
+ va_end(args);
+
+ exit(EXIT_FAILURE);
+}
diff --git a/dev-util/lockrun/lockrun-20120508.ebuild b/dev-util/lockrun/lockrun-20120508.ebuild
new file mode 100644
index 000000000000..5e7e1ef7e0d5
--- /dev/null
+++ b/dev-util/lockrun/lockrun-20120508.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Lockrun - runs cronjobs with overrun protection"
+HOMEPAGE="http://www.unixwiz.net/tools/lockrun.html"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 hppa x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp "${FILESDIR}"/${PN}.c-${PV} "${S}"/${PN}.c || die
+ cp "${FILESDIR}"/${PN}.c-${PV} "${S}"/README || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) ${PN}
+ sed -i README -e '60q;s|^ \*||g' || die
+}
+
+src_install () {
+ dobin ${PN}
+ dodoc README
+}
diff --git a/dev-util/lockrun/metadata.xml b/dev-util/lockrun/metadata.xml
new file mode 100644
index 000000000000..a40624fba8f0
--- /dev/null
+++ b/dev-util/lockrun/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>