summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/httpup
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/httpup')
-rw-r--r--dev-util/httpup/Manifest1
-rw-r--r--dev-util/httpup/files/httpup-0.4.0k-Makefile.patch26
-rw-r--r--dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch15
-rw-r--r--dev-util/httpup/httpup-0.4.0k.ebuild33
-rw-r--r--dev-util/httpup/metadata.xml7
5 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/httpup/Manifest b/dev-util/httpup/Manifest
new file mode 100644
index 000000000000..bdf9ee404c2b
--- /dev/null
+++ b/dev-util/httpup/Manifest
@@ -0,0 +1 @@
+DIST httpup-0.4.0k.tar.gz 27167 SHA256 780043fa99e9c1b09b115f4e0a71fc4aeb7278a59fbfcd65c9d34385ee52f3d6 SHA512 9a7299390cd5b5b8cfcfce60ff65eb34f80b96e4a894bd42ac204d2b80d9f9376a892123c161dd1aadf3080d622212bd131e5a61405ef45f6048c360abe512b4 WHIRLPOOL 19c47010f45c7597dce5fcaaa245482743499864bbbe33f02bfe3496cfa6d70f8e384d9c099ac78ffcb60bfbd95cecb2dfafb81768a280cc8ca14494d97c94ca
diff --git a/dev-util/httpup/files/httpup-0.4.0k-Makefile.patch b/dev-util/httpup/files/httpup-0.4.0k-Makefile.patch
new file mode 100644
index 000000000000..9676e8d1b777
--- /dev/null
+++ b/dev-util/httpup/files/httpup-0.4.0k-Makefile.patch
@@ -0,0 +1,26 @@
+--- Makefile
++++ Makefile
+@@ -8,10 +8,10 @@
+ mandir= $(prefix)/man
+
+
+-CXX= g++
+-CXXFLAGS= -O2 -pipe -DMF_VERSION=\"${version}\"
+-CXXFLAGS+= -g -Wall -Werror
+-LDFLAGS= -lcurl
++CXX?= g++
++CXXFLAGS+= -DMF_VERSION=\"${version}\"
++CXXFLAGS+= -Wall
++LIBS= -lcurl
+
+ INSTALL= /usr/bin/install
+ STRIP= /usr/bin/strip
+@@ -36,7 +36,7 @@
+
+
+ $(name): $(OBJS)
+- $(CXX) $(LDFLAGS) $(OBJS) -o $(name)
++ $(CXX) $(LDFLAGS) $(OBJS) -o $(name) $(LIBS)
+
+ distclean: clean
+ -rm -f Makefile config.log config.h *~ *.core core.*
diff --git a/dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch b/dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch
new file mode 100644
index 000000000000..c015cecaf538
--- /dev/null
+++ b/dev-util/httpup/files/httpup-0.4.0k-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ main.cpp | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/main.cpp b/main.cpp
+index 3040b9d..2d807ed 100644
+--- a/main.cpp
++++ b/main.cpp
+@@ -12,6 +12,7 @@
+ #include <iostream>
+ #include <string>
+ #include <cstdlib>
++#include <unistd.h>
+ using namespace std;
+
+ #include "httpup.h"
diff --git a/dev-util/httpup/httpup-0.4.0k.ebuild b/dev-util/httpup/httpup-0.4.0k.ebuild
new file mode 100644
index 000000000000..df85092889f1
--- /dev/null
+++ b/dev-util/httpup/httpup-0.4.0k.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="synchronisation tool for http file repositories"
+HOMEPAGE="http://jw.tks6.net/files/crux/httpup_manual.html"
+SRC_URI="http://jw.tks6.net/files/crux/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DEPEND="net-misc/curl"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-Makefile.patch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ tc-export CC CXX
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ mandir="${EPREFIX}/usr/share/man" \
+ prefix="${EPREFIX}/usr" install
+ dodoc AUTHORS ChangeLog httpup.conf.example README TODO
+}
diff --git a/dev-util/httpup/metadata.xml b/dev-util/httpup/metadata.xml
new file mode 100644
index 000000000000..91f4e72fb544
--- /dev/null
+++ b/dev-util/httpup/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>