summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-10-17 14:08:07 +0200
committerSebastian Pipping <sping@gentoo.org>2021-10-17 14:23:42 +0200
commitf40563304c5c99ecd1d640264a6b8a95a392dd65 (patch)
tree22305c1b2d337f6648b8854e8cf53540a24237b3 /dev-util/gprof2dot
parentx11-terms/xfce4-terminal: Bump to 0.9.0 (devel) (diff)
downloadgentoo-f40563304c5c99ecd1d640264a6b8a95a392dd65.tar.gz
gentoo-f40563304c5c99ecd1d640264a6b8a95a392dd65.tar.bz2
gentoo-f40563304c5c99ecd1d640264a6b8a95a392dd65.zip
dev-util/gprof2dot: py3.10 + DISTUTILS_USE_SETUPTOOLS
Closes: https://bugs.gentoo.org/818574 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.23, Repoman-3.0.3
Diffstat (limited to 'dev-util/gprof2dot')
-rw-r--r--dev-util/gprof2dot/gprof2dot-2021.02.21-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/gprof2dot/gprof2dot-2021.02.21-r1.ebuild b/dev-util/gprof2dot/gprof2dot-2021.02.21-r1.ebuild
new file mode 100644
index 000000000000..877e56b88b78
--- /dev/null
+++ b/dev-util/gprof2dot/gprof2dot-2021.02.21-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE='xml'
+
+inherit distutils-r1
+
+MY_PV=${PV//.0/.}
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Converts profiling output to dot graphs"
+HOMEPAGE="https://github.com/jrfonseca/gprof2dot"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${MY_P}