summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-01-26 09:43:30 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-01-26 09:43:30 -0600
commit1f54316bf14049c152eee8b20ed03d78a89d9051 (patch)
tree9f1c163df3116c8c4d5c24fc67010a4cb9210148 /dev-util/gitlab-runner
parentsys-kernel/gentoo-kernel-bin: Bump to 6.7.2 (diff)
downloadgentoo-1f54316bf14049c152eee8b20ed03d78a89d9051.tar.gz
gentoo-1f54316bf14049c152eee8b20ed03d78a89d9051.tar.bz2
gentoo-1f54316bf14049c152eee8b20ed03d78a89d9051.zip
dev-util/gitlab-runner: add 16.8.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.8.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 41828acfb35e..bae19e6fcb41 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-16.6.1-deps.tar.xz 223030236 BLAKE2B 76866243ed71a907b0eb8d99
DIST gitlab-runner-16.6.1.tar.bz2 1335597 BLAKE2B 5432b008c38e0ce4f6d9026f82f964a2b929b81165d5694b05d740e5db3d561e7856842dec1d0bd17595832a6321f5d060da6e1be0f12da6a66608226089af97 SHA512 14a30a276c46b43b7b5b6a766eb287beecb434a2c6cadaababdd6de0b265f23de2dc3b8387f8110889cf3cca70ad95bffcbfed7cf0d5543604ee3aebc4cad579
DIST gitlab-runner-16.7.0-deps.tar.xz 236174584 BLAKE2B 54372f6f817fdbcb208924c563c07300911cde664035f50f0324785cadbacaa353cdb532045f4b41a6b026f80fc440f8756260d7524094e6e777835db5388d89 SHA512 95c32c55a6bde15db4ea9c82cb76952f4b51b98a6b3e02047e51ae9510e1d9189248d44545f665c7db588e26c58f20c6ef13c7692376a07c4afcf98cf96eae26
DIST gitlab-runner-16.7.0.tar.bz2 1349700 BLAKE2B 3371e91a8881b9b0f9ada5ed05509db2b8052e4570aeabe7555474450897815ebd7bd81cbc979e75cd871f1d61ded0670ebcf91890b2a57de0b7c771698f6739 SHA512 21f1ecdf181dd7d62d92709e2efd9a9373e0c7a807ddba035becdc8b98b8f2a18bc3ac21f23af3c060e8b3e650b81c213c93068345f19789df904837fd00e4d5
+DIST gitlab-runner-16.8.0-deps.tar.xz 236205192 BLAKE2B f9cd36f0bc0514e5bc20b17b4df7fd35e6e435a66569172935a0590ed354f3aec0c8f570f085ee7105ddabde8dc307a32770638cb26cf36aa6cb16810f43cd4b SHA512 6eb4713703a15e129111f5ae11620600e175ca8063435daee6d87b961f43d44f672393ff5c28734837d7dabcbd69257e1e787dfb47bfa32d326db01ecb988611
+DIST gitlab-runner-16.8.0.tar.bz2 1351894 BLAKE2B a2179c5d728895574d24471ec4de7bb02aa8c07b256e5c3ad90777652af9d44d9951cec4b153a232c24388461184061e23b75a4813a6987fee03823c692d51ce SHA512 5822a097ff9d03540b89d809a5851a4b1e55e193499e23af20a259c07cf4840b4db2edc6616113d40cf35ed1cd94a8db04178ad55b94a6b42e2f9c7a306c672d
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.8.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.8.0.ebuild
new file mode 100644
index 000000000000..371c96ce202a
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-16.8.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=c72a09b6
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}