summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/geany-plugins
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/geany-plugins')
-rw-r--r--dev-util/geany-plugins/Manifest2
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.23.ebuild101
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.24-r1.ebuild118
-rw-r--r--dev-util/geany-plugins/metadata.xml23
4 files changed, 244 insertions, 0 deletions
diff --git a/dev-util/geany-plugins/Manifest b/dev-util/geany-plugins/Manifest
new file mode 100644
index 000000000000..e6b8972f4c43
--- /dev/null
+++ b/dev-util/geany-plugins/Manifest
@@ -0,0 +1,2 @@
+DIST geany-plugins-1.23.tar.gz 3642803 SHA256 b0e79c1cd679a5b5f02632922920478a1047c3a5985982a1cc2348fa7e4454c4 SHA512 68ba0c96712cd6ea944ff68810378a96a411717a0950bfc72f5aade36bf6e5b065d229beec3b5724921c2eaf4ddb73a19f4ae77137a96208fef52f739d65c6ef WHIRLPOOL 56e54586611f8e804059b489d54d2e3970f9cf7c958e99169eeee96472c2d7848aa446bc74a150bd32ec18aa6daaba030939facaada376327fea5e90e2a15e9c
+DIST geany-plugins-1.24.tar.gz 4037065 SHA256 2e5fa09afe7710cdc2eebae3656d56561429d5df8898c6b5dc91915f15aec0fc SHA512 947bdf8bd602ae5576d3298029d7249ac40881c13cb3676123c92f4b183be200126d0e19e5c0697c237e5a8d3d9f2d7d715b0cd562f98a059af9fa5d4f3e611e WHIRLPOOL 4386cedfef05c5f4b0bb218122b20a84167bc0b2e43b06bf080ac21dd111b57d9fbf770af78d16394d0ee01592849fae8466e8467bc05176fafd331ba0f7d2a7
diff --git a/dev-util/geany-plugins/geany-plugins-1.23.ebuild b/dev-util/geany-plugins/geany-plugins-1.23.ebuild
new file mode 100644
index 000000000000..00f5e337c2ba
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.23.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils vala versionator
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="http://plugins.geany.org/geany-plugins"
+SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+IUSE="+commander debugger devhelp enchant gpg gtkspell lua markdown multiterm nls scope soup webkit"
+
+LINGUAS="be ca da de es fr gl ja pt pt_BR ru tr zh_CN"
+
+COMMON_DEPEND=">=dev-util/geany-$(get_version_component_range 1-2)
+ commander? ( x11-libs/gtk+:2 )
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ debugger? ( x11-libs/vte:0 )
+ devhelp? (
+ dev-util/devhelp
+ gnome-base/gconf:2
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libwnck:1
+ )
+ enchant? ( app-text/enchant )
+ gpg? ( app-crypt/gpgme )
+ gtkspell? ( app-text/gtkspell:2 )
+ lua? ( dev-lang/lua )
+ markdown? (
+ app-text/discount
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ )
+ multiterm? (
+ $(vala_depend)
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.28:0
+ )
+ scope? ( x11-libs/vte:0 )
+ soup? ( net-libs/libsoup )
+ webkit? (
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ )"
+RDEPEND="${COMMON_DEPEND}
+ scope? ( sys-devel/gdb )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ # bundled lib buster
+ rm markdown/peg-markdown/markdown_lib.c || die
+
+ autotools-utils_src_prepare
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ --disable-geanygendoc
+ # peg-markdown is bundled, use app-text/discount instead
+ --disable-peg-markdown
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-gproject
+ --enable-pretty-printer
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-xmlsnippets
+ $(use_enable commander)
+ $(use_enable debugger)
+ $(use_enable devhelp)
+ $(use_enable enchant spellcheck)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable markdown)
+ $(use_enable multiterm)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ $(use_enable scope)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable soup geniuspaste)
+ $(use_enable webkit webhelper)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/geany-plugins/geany-plugins-1.24-r1.ebuild b/dev-util/geany-plugins/geany-plugins-1.24-r1.ebuild
new file mode 100644
index 000000000000..5b32351161bc
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.24-r1.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-single-r1 vala versionator
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="http://plugins.geany.org/geany-plugins"
+SRC_URI="http://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~ia64 ppc ~ppc64 sparc x86"
+IUSE="+autoclose +commander debugger +defineformat devhelp enchant gpg gtkspell lua markdown multiterm nls python scope soup webkit"
+
+LINGUAS="be ca da de es fr gl ja pt pt_BR ru tr zh_CN"
+
+COMMON_DEPEND=">=dev-util/geany-$(get_version_component_range 1-2)
+ autoclose? ( x11-libs/gtk+:2 )
+ commander? ( x11-libs/gtk+:2 )
+ defineformat? ( x11-libs/gtk+:2 )
+ dev-libs/libxml2:2
+ dev-libs/glib:2
+ debugger? ( x11-libs/vte:0 )
+ devhelp? (
+ dev-util/devhelp
+ gnome-base/gconf:2
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/libwnck:1
+ )
+ enchant? ( app-text/enchant )
+ gpg? ( app-crypt/gpgme )
+ gtkspell? ( app-text/gtkspell:2 )
+ lua? ( dev-lang/lua )
+ markdown? (
+ app-text/discount
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ )
+ multiterm? (
+ $(vala_depend)
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.28:0
+ )
+ python? (
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ scope? ( x11-libs/vte:0 )
+ soup? ( net-libs/libsoup )
+ webkit? (
+ net-libs/webkit-gtk:2
+ x11-libs/gtk+:2
+ x11-libs/gdk-pixbuf:2
+ )"
+RDEPEND="${COMMON_DEPEND}
+ scope? ( sys-devel/gdb )"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # bundled lib buster
+ rm markdown/peg-markdown/markdown_lib.c || die
+
+ autotools-utils_src_prepare
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ --disable-geanygendoc
+ # peg-markdown is bundled, use app-text/discount instead
+ --disable-peg-markdown
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-gproject
+ --enable-pretty-printer
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-xmlsnippets
+ $(use_enable autoclose)
+ $(use_enable commander)
+ $(use_enable debugger)
+ $(use_enable defineformat)
+ $(use_enable devhelp)
+ $(use_enable enchant spellcheck)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable markdown)
+ $(use_enable multiterm)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ $(use_enable python geanypy)
+ $(use_enable scope)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable soup geniuspaste)
+ $(use_enable webkit webhelper)
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
new file mode 100644
index 000000000000..0f39490cad47
--- /dev/null
+++ b/dev-util/geany-plugins/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>binki@gentoo.org</email>
+ <name>Nathan Phillip Brink</name>
+ </maintainer>
+ <use>
+ <flag name='autoclose'>Enable the autoclose plugin.</flag>
+ <flag name='commander'>Enable the commander plugin which provides a command panel for rapid access to any action.</flag>
+ <flag name='debugger'>Enable the debugger plugin which interfaces with <pkg>sys-devel/gdb</pkg></flag>
+ <flag name='defineformat'>Enable the defineformat plugin.</flag>
+ <flag name='devhelp'>Enable the devhelp plugin which integrates <pkg>dev-util/devhelp</pkg></flag>
+ <flag name='enchant'>Enable spell checking using enchant</flag>
+ <flag name='gpg'>Enable geanypg plugin which integrates GPG using <pkg>app-crypt/gpgme</pkg></flag>
+ <flag name='gtkspell'>Use gtkspell for dictionary support</flag>
+ <flag name='markdown'>Enable the markdown plugin which uses <pkg>app-text/discount</pkg> and <pkg>net-libs/webkit-gtk</pkg> to display a realtime preview markdown.</flag>
+ <flag name='multiterm'>Enable the multiterm plugin</flag>
+ <flag name='scope'>Enable the scope plugin which is a graphical GDB front-end</flag>
+ <flag name='soup'>Enable updatechecker and geniuspaste plugins which require <pkg>net-libs/libsoup</pkg></flag>
+ <flag name='webkit'>Enable webhelper plugin which requires <pkg>net-libs/webkit-gtk</pkg></flag>
+ </use>
+</pkgmetadata>