summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/dmake
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/dmake')
-rw-r--r--dev-util/dmake/Manifest1
-rw-r--r--dev-util/dmake/dmake-4.12.2.ebuild36
-rw-r--r--dev-util/dmake/files/4.12-fix-overlapping-stcpys.patch233
-rw-r--r--dev-util/dmake/files/dmake-4.1-r1.diff170
-rw-r--r--dev-util/dmake/metadata.xml9
5 files changed, 449 insertions, 0 deletions
diff --git a/dev-util/dmake/Manifest b/dev-util/dmake/Manifest
new file mode 100644
index 000000000000..36400fda1273
--- /dev/null
+++ b/dev-util/dmake/Manifest
@@ -0,0 +1 @@
+DIST dmake-4.12.2.tar.bz2 461738 SHA256 2fcbf389a9baaec25a973bd0d9e338069ad427b17d2adc7dc023efb034e96057 SHA512 f09453205bd425882d933a7b2cf879d69d795765bb7586e1e35ca5c9e39444cb70cfe56ed9b350f12fae8d484670b4ae418bb5d2da7c0c2ff229d9165caff45b WHIRLPOOL d1d5f9f34302ba5d2b98e8016b27a46c0b0e67cc98e25867a6af4659c3b39ba1ae93d8d642d0cd5cc7a2a58cf7f1e9c01fc20079a41ba67ee65c929188a6b2e1
diff --git a/dev-util/dmake/dmake-4.12.2.ebuild b/dev-util/dmake/dmake-4.12.2.ebuild
new file mode 100644
index 000000000000..38e07de0672b
--- /dev/null
+++ b/dev-util/dmake/dmake-4.12.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Improved make"
+HOMEPAGE="http://code.google.com/a/apache-extras.org/p/dmake/"
+SRC_URI="http://${PN}.apache-extras.org.codespot.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+# test failure, reported upstream at
+# http://code.google.com/a/apache-extras.org/p/dmake/issues/detail?id=1
+RESTRICT="test"
+
+DEPEND="
+ app-arch/unzip
+ sys-apps/groff
+"
+RDEPEND=""
+
+src_prepare() {
+ # make tests executable, bug #404989
+ chmod +x tests/targets-{1..12} || die
+}
+
+src_install () {
+ default
+ newman man/dmake.tf dmake.1
+}
diff --git a/dev-util/dmake/files/4.12-fix-overlapping-stcpys.patch b/dev-util/dmake/files/4.12-fix-overlapping-stcpys.patch
new file mode 100644
index 000000000000..b79a53ba0eb8
--- /dev/null
+++ b/dev-util/dmake/files/4.12-fix-overlapping-stcpys.patch
@@ -0,0 +1,233 @@
+diff -ru dmake.orig/rulparse.c dmake/rulparse.c
+--- dmake.orig/rulparse.c 2009-07-29 13:31:47.000000000 +0100
++++ dmake/rulparse.c 2009-07-29 13:32:09.000000000 +0100
+@@ -897,7 +897,7 @@
+ /* Handle %-targets. */
+ CELLPTR cur;
+ CELLPTR tpq = NIL(CELL);
+- CELLPTR nprq;
++ CELLPTR nprq = NULL;
+
+ #ifdef DBUG
+ DB_PRINT( "%", ("Handling %%-target [%s : : <prerequisites follow, maybe empty>]",
+@@ -915,7 +915,8 @@
+
+ if( *name == '\'' && name[len-1]=='\'' ){
+ name[len-1] = '\0';
+- strcpy(name,name+1);
++ len = strlen(name+1)+1;
++ memmove(name,name+1,len);
+ /* add indirect prerequisite */
+ _add_indirect_prereq( cur );
+ }
+diff -ru dmake.orig/dag.c dmake/dag.c
+--- dmake.orig/dag.c 2009-08-07 20:18:31.000000000 +0100
++++ dmake/dag.c 2009-08-07 20:30:59.000000000 +0100
+@@ -369,14 +369,17 @@
+ /* strip out any \<nl> combinations where \ is the current
+ * CONTINUATION char */
+ for(p=q; (p=strchr(p,CONTINUATION_CHAR))!=NIL(char); )
+- if( p[1] == '\n' )
+- strcpy( p, p+2 );
++ if( p[1] == '\n' ) {
++ size_t len = strlen(p+2)+1;
++ memmove ( p, p+2, len );
++ }
+ else
+ p++;
+
+ p = DmStrSpn(q ," \t"); /* Strip white space before ... */
+ if( p != q ) {
+- strcpy( q, p);
++ size_t len = strlen(p)+1;
++ memmove( q, p, len );
+ p = q;
+ }
+
+diff -ru dmake.orig/expand.c dmake/expand.c
+--- dmake.orig/expand.c 2009-08-07 20:18:34.000000000 +0100
++++ dmake/expand.c 2009-08-07 20:42:40.000000000 +0100
+@@ -230,6 +230,7 @@
+ char *tok;
+ {
+ if( strchr( "\"\\vantbrf01234567", tok[1] ) ) {
++ size_t len;
+ switch( tok[1] ) {
+ case 'a' : *tok = 0x07; break;
+ case 'b' : *tok = '\b'; break;
+@@ -246,13 +247,15 @@
+ register int j = 0;
+ for( ; i<2 && isdigit(tok[2]); i++ ) {
+ j = (j << 3) + (tok[1] - '0');
+- strcpy( tok+1, tok+2 );
++ len = strlen(tok+2)+1;
++ memmove( tok+1, tok+2, len );
+ }
+ j = (j << 3) + (tok[1] - '0');
+ *tok = j;
+ }
+ }
+- strcpy( tok+1, tok+2 );
++ len = strlen(tok+2)+1;
++ memmove( tok+1, tok+2, len );
+ }
+ }
+
+@@ -365,7 +368,8 @@
+ if( (e = Basename(s)) != s) {
+ if( !(mod & DIRECTORY_FLAG) ) {
+ /* Move the basename to the start. */
+- strcpy(s, e);
++ size_t len = strlen(e)+1;
++ memmove(s, e, len);
+ }
+ else
+ s = e;
+@@ -382,7 +386,8 @@
+
+ if( !(mod & FILE_FLAG) ) {
+ /* Move the suffix to the start. */
+- strcpy( s, e );
++ size_t len = strlen(e)+1;
++ memmove(s, e, len);
+ }
+ else
+ s = e;
+@@ -725,8 +730,10 @@
+ done = !lev;
+ break;
+ } else {
++ size_t len;
+ s[1] = ' ';
+- strcpy( s, s+1 );
++ len = strlen(s+1)+1;
++ memmove( s, s+1, len );
+ }
+ /*FALLTHRU*/
+ case ' ':
+@@ -835,8 +842,10 @@
+ * converted them to a real space. Let's verify this. */
+ for( p=s; *p && *p != edelim && *p; p++ ) {
+ if( p[0] == '\\' && p[1] == '\n' ) {
++ size_t len;
+ p[1] = ' ';
+- strcpy( p, p+1 );
++ len = strlen(p+1)+1;
++ memmove( p, p+1, len );
+ }
+ }
+ if( !*p )
+@@ -1120,7 +1129,10 @@
+ *flag = 1;
+ res = Expand( start );
+
+- if( (t = DmStrSpn( res, " \t" )) != res ) strcpy( res, t );
++ if( (t = DmStrSpn( res, " \t" )) != res ) {
++ size_t len = strlen(t)+1;
++ memmove( res, t, len );
++ }
+ }
+
+ FREE( start ); /* this is ok! start is assigned a DmSubStr above */
+diff -ru dmake.orig/getinp.c dmake/getinp.c
+--- dmake.orig/getinp.c 2009-08-07 20:18:31.000000000 +0100
++++ dmake/getinp.c 2009-08-07 20:27:08.000000000 +0100
+@@ -169,7 +169,8 @@
+ * text lines on input. The maximum size of this is governened by
+ * Buffer_size */
+ if( q != p && q[-1] == CONTINUATION_CHAR ) {
+- strcpy( q, q+1 );
++ size_t len = strlen(q+1)+1;
++ memmove( q, q+1, len );
+ q--;
+ cont = FALSE;
+ }
+@@ -290,7 +291,8 @@
+ while( (c = strchr(c, COMMENT_CHAR)) != NIL(char) ) {
+ if( Comment || State == NORMAL_SCAN )
+ if( c != str && c[-1] == ESCAPE_CHAR ) {
+- strcpy( c-1, c ); /* copy it left, due to \# */
++ size_t len = strlen(c)+1;
++ memmove( c-1, c, len ); /* copy it left, due to \# */
+ if( pend ) (*pend)--; /* shift tail pointer left */
+ }
+ else {
+diff -ru dmake.orig/path.c dmake/path.c
+--- dmake.orig/path.c 2009-08-07 20:18:31.000000000 +0100
++++ dmake/path.c 2009-08-07 20:41:30.000000000 +0100
+@@ -172,6 +172,7 @@
+ char *tpath;
+ int hasdriveletter = 0;
+ int delentry;
++ size_t len;
+
+ DB_ENTER( "Clean_path" );
+
+@@ -231,14 +232,16 @@
+ p++;
+ }
+ while( *p == *DirSepStr);
+- strcpy(t+1,p);
++ len = strlen(p)+1;
++ memmove(t+1,p,len);
+ continue;
+ }
+
+ /* Remove './'. If OOODMAKEMODE is set do this only if it is not at
+ * the start of the path. */
+ if ( p-q == 1 && *q == '.' && (q != path || !STOBOOL(OOoDmMode)) ) {
+- strcpy(q,p+1);
++ len = strlen(p+1)+1;
++ memmove(q,p+1,len);
+ q = tpath;
+ continue;
+ }
+@@ -268,7 +271,8 @@
+ }
+ while( *t == *DirSepStr);
+ /* q points to first letter of the current directory/file. */
+- strcpy(q,t);
++ len = strlen(t)+1;
++ memmove(q,t,len);
+ q = tpath;
+ }
+ else
+--- dmake.orig/make.c 2009-08-08 09:56:10.000000000 +0100
++++ dmake/make.c 2009-08-08 10:00:04.000000000 +0100
+@@ -1352,8 +1352,10 @@
+ * Nothing in Expand() should be able to change dynamic macros. */
+ cmnd = Expand( rp->st_string );
+
+- if( new_attr && (p = DmStrSpn(cmnd," \t\n+-@%")) != cmnd )
+- strcpy(cmnd,p);
++ if( new_attr && (p = DmStrSpn(cmnd," \t\n+-@%")) != cmnd ) {
++ size_t len = strlen(p)+1;
++ memmove(cmnd,p,len);
++ }
+
+ /* COMMAND macro is set to "$(CMNDNAME) $(CMNDARGS)" by default, it is
+ * possible for the user to reset it to, for example
+@@ -1381,8 +1383,10 @@
+ shell = ((l_attr & A_SHELL) != 0);
+
+ /* clean up the attributes that we may have just added. */
+- if( (p = DmStrSpn(cmnd," \t\n+-@%")) != cmnd )
+- strcpy(cmnd,p);
++ if( (p = DmStrSpn(cmnd," \t\n+-@%")) != cmnd ) {
++ size_t len = strlen(p)+1;
++ memmove(cmnd,p,len);
++ }
+ }
+
+ #if defined(MSDOS)
+@@ -1477,8 +1481,9 @@
+ for( p=cmnd; *(n = DmStrPbrk(p,tmp)) != '\0'; )
+ /* Remove the \<nl> sequences. */
+ if(*n == CONTINUATION_CHAR && n[1] == '\n') {
++ size_t len = strlen(n+2)+1;
+ DB_PRINT( "make", ("fixing [%s]", p) );
+- strcpy( n, n+2 );
++ memmove( n, n+2, len );
+ p = n;
+ }
+ /* Look for an escape sequence and replace it by it's corresponding
diff --git a/dev-util/dmake/files/dmake-4.1-r1.diff b/dev-util/dmake/files/dmake-4.1-r1.diff
new file mode 100644
index 000000000000..3655a6bb067e
--- /dev/null
+++ b/dev-util/dmake/files/dmake-4.1-r1.diff
@@ -0,0 +1,170 @@
+diff -ur dmake.orig/dbug/malloc/testmem.c dmake-4.1/dbug/malloc/testmem.c
+--- dmake.orig/dbug/malloc/testmem.c 1997-07-15 17:02:26.000000000 +0100
++++ dmake-4.1/dbug/malloc/testmem.c 2003-03-10 15:02:38.000000000 +0000
+@@ -64,7 +64,7 @@
+ int f;
+ extern char *sys_errlist[];
+ extern int sys_nerr;
+-extern int errno;
++#include <errno.h>
+ #endif
+
+ /* ARGSUSED */
+diff -ur dmake.orig/qssl/runargv.c dmake-4.1/qssl/runargv.c
+--- dmake.orig/qssl/runargv.c 1997-07-15 17:02:29.000000000 +0100
++++ dmake-4.1/qssl/runargv.c 2003-03-10 15:03:09.000000000 +0000
+@@ -24,6 +24,7 @@
+ */
+
+ #include <signal.h>
++#include <errno.h>
+ #include "extern.h"
+ #include "sysintf.h"
+
+@@ -67,7 +68,6 @@
+ int shell;
+ char *cmd;
+ {
+- extern int errno;
+ int pid;
+ char **argv;
+
+diff -ur dmake.orig/qssl/stdlib.h dmake-4.1/qssl/stdlib.h
+--- dmake.orig/qssl/stdlib.h 1997-07-15 17:02:29.000000000 +0100
++++ dmake-4.1/qssl/stdlib.h 2003-03-10 15:03:35.000000000 +0000
+@@ -39,7 +39,7 @@
+ extern free();
+ #endif
+
+-extern int errno;
++#include <errno.h>
+
+ #ifndef EIO
+ # include <errno.h>
+diff -ur dmake.orig/unix/386ix/stdlib.h dmake-4.1/unix/386ix/stdlib.h
+--- dmake.orig/unix/386ix/stdlib.h 1997-07-15 17:02:34.000000000 +0100
++++ dmake-4.1/unix/386ix/stdlib.h 2003-03-10 15:04:33.000000000 +0000
+@@ -35,7 +35,7 @@
+ extern char *malloc();
+ extern char *realloc();
+ extern free();
+-extern int errno;
++#include <errno.h>
+
+ #ifndef EIO
+ # include <errno.h>
+diff -ur dmake.orig/unix/bsd43/stdlib.h dmake-4.1/unix/bsd43/stdlib.h
+--- dmake.orig/unix/bsd43/stdlib.h 1997-07-15 17:02:35.000000000 +0100
++++ dmake-4.1/unix/bsd43/stdlib.h 2003-03-10 15:04:55.000000000 +0000
+@@ -35,7 +35,7 @@
+ extern char *malloc();
+ extern char *realloc();
+ extern free();
+-extern int errno;
++#include <errno.h>
+
+ #ifndef EIO
+ # include <errno.h>
+diff -ur dmake.orig/unix/coherent/stdlib.h dmake-4.1/unix/coherent/stdlib.h
+--- dmake.orig/unix/coherent/stdlib.h 1997-07-15 17:02:35.000000000 +0100
++++ dmake-4.1/unix/coherent/stdlib.h 2003-03-10 15:05:33.000000000 +0000
+@@ -35,7 +35,7 @@
+ extern char *malloc();
+ extern char *realloc();
+ extern free();
+-extern int errno;
++#include <errno.h>
+
+ #ifndef EIO
+ # include <errno.h>
+diff -ur dmake.orig/unix/runargv.c dmake-4.1/unix/runargv.c
+--- dmake.orig/unix/runargv.c 1997-07-15 17:02:34.000000000 +0100
++++ dmake-4.1/unix/runargv.c 2003-03-10 15:05:53.000000000 +0000
+@@ -24,6 +24,7 @@
+ */
+
+ #include <signal.h>
++#include <errno.h>
+ #include "extern.h"
+ #include "sysintf.h"
+
+@@ -67,8 +68,7 @@
+ int shell;
+ char *cmd;
+ {
+- extern int errno;
+- extern char *sys_errlist[];
++
+ int pid;
+ char **argv;
+
+diff -ur dmake.orig/unix/startup.h dmake-4.1/unix/startup.h
+--- dmake.orig/unix/startup.h 1997-07-15 17:02:34.000000000 +0100
++++ dmake-4.1/unix/startup.h 2003-03-10 15:00:46.000000000 +0000
+@@ -24,4 +24,4 @@
+ -- Use cvs log to obtain detailed change logs.
+ */
+
+-"MAKESTARTUP := $(ROOTDIR)/usr/local/lib/dmake/startup/startup.mk",
++"MAKESTARTUP := $(ROOTDIR)/usr/share/dmake/startup/startup.mk",
+diff -ur dmake.orig/unix/sysvr1/stdlib.h dmake-4.1/unix/sysvr1/stdlib.h
+--- dmake.orig/unix/sysvr1/stdlib.h 1997-07-15 17:02:36.000000000 +0100
++++ dmake-4.1/unix/sysvr1/stdlib.h 2003-03-10 15:06:16.000000000 +0000
+@@ -35,7 +35,7 @@
+ extern char *malloc();
+ extern char *realloc();
+ extern free();
+-extern int errno;
++#include <errno.h>
+
+ #ifndef EIO
+ # include <errno.h>
+diff -ur dmake.orig/unix/sysvr3/stdlib.h dmake-4.1/unix/sysvr3/stdlib.h
+--- dmake.orig/unix/sysvr3/stdlib.h 1997-07-15 17:02:36.000000000 +0100
++++ dmake-4.1/unix/sysvr3/stdlib.h 2003-03-10 15:06:50.000000000 +0000
+@@ -46,10 +46,6 @@
+ #define NAME_MAX pathconf("/dev/null",_PC_NAME_MAX)
+ #endif
+
+-extern int errno;
+-
+-#ifndef EIO
+-# include <errno.h>
+-#endif
++#include <errno.h>
+
+ #endif /* _STDLIB_INCLUDED_ */
+diff -ur dmake.orig/unix/xenix/stdlib.h dmake-4.1/unix/xenix/stdlib.h
+--- dmake.orig/unix/xenix/stdlib.h 1997-07-15 17:02:36.000000000 +0100
++++ dmake-4.1/unix/xenix/stdlib.h 2003-03-10 15:05:15.000000000 +0000
+@@ -41,7 +41,7 @@
+ extern free();
+ #endif
+
+-extern int errno;
++#include <errno.h>
+
+ #ifndef EIO
+ # include <errno.h>
+diff -ur dmake.orig/win95/microsft/vpp40/runargv.c dmake-4.1/win95/microsft/vpp40/runargv.c
+--- dmake.orig/win95/microsft/vpp40/runargv.c 1997-07-15 17:02:37.000000000 +0100
++++ dmake-4.1/win95/microsft/vpp40/runargv.c 2003-03-10 15:07:06.000000000 +0000
+@@ -73,7 +73,6 @@
+ int shell;
+ char *cmd;
+ {
+- extern int errno;
+ extern char *sys_errlist[];
+ int pid;
+ char **argv;
+diff -ur dmake.orig/winnt/microsft/vpp40/runargv.c dmake-4.1/winnt/microsft/vpp40/runargv.c
+--- dmake.orig/winnt/microsft/vpp40/runargv.c 1997-07-15 17:02:38.000000000 +0100
++++ dmake-4.1/winnt/microsft/vpp40/runargv.c 2003-03-10 15:07:21.000000000 +0000
+@@ -73,7 +73,6 @@
+ int shell;
+ char *cmd;
+ {
+- extern int errno;
+ extern char *sys_errlist[];
+ int pid;
+ char **argv;
diff --git a/dev-util/dmake/metadata.xml b/dev-util/dmake/metadata.xml
new file mode 100644
index 000000000000..8a9b49eec325
--- /dev/null
+++ b/dev-util/dmake/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>chithanh@gentoo.org</email>
+ <name>Chí-Thanh Christopher Nguyễn</name>
+ </maintainer>
+</pkgmetadata>
+