summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-12-02 09:30:33 -0800
committerPatrick McLean <chutzpah@gentoo.org>2021-12-02 09:30:48 -0800
commitef0f3b1bb4c6bfb876c0af6cb1bcddff39dcef3b (patch)
treedfb833ad0566bde6bc646a7a09884e29deb5fb68 /dev-util/bpftrace/files
parentwww-client/chromium: dev channel bump to 98.0.4736.0 (diff)
downloadgentoo-ef0f3b1bb4c6bfb876c0af6cb1bcddff39dcef3b.tar.gz
gentoo-ef0f3b1bb4c6bfb876c0af6cb1bcddff39dcef3b.tar.bz2
gentoo-ef0f3b1bb4c6bfb876c0af6cb1bcddff39dcef3b.zip
dev-util/bpftrace: Fix build with libbpf-0.6.0
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-util/bpftrace/files')
-rw-r--r--dev-util/bpftrace/files/bpftrace-0.14-libbpf-0.6.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/dev-util/bpftrace/files/bpftrace-0.14-libbpf-0.6.patch b/dev-util/bpftrace/files/bpftrace-0.14-libbpf-0.6.patch
new file mode 100644
index 000000000000..e4a383dd69fc
--- /dev/null
+++ b/dev-util/bpftrace/files/bpftrace-0.14-libbpf-0.6.patch
@@ -0,0 +1,17 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 47a050e2..5dd5ff3f 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -123,10 +123,8 @@ endif(STATIC_LINKING)
+
+ target_link_libraries(libbpftrace parser resources runtime aot ast arch cxxdemangler_llvm)
+
+-if (LIBBPF_BTF_DUMP_FOUND)
+- target_include_directories(runtime PUBLIC ${LIBBPF_INCLUDE_DIRS})
+- target_link_libraries(runtime ${LIBBPF_LIBRARIES})
+-endif(LIBBPF_BTF_DUMP_FOUND)
++target_include_directories(runtime PUBLIC ${LIBBPF_INCLUDE_DIRS})
++target_link_libraries(runtime ${LIBBPF_LIBRARIES})
+
+ if(HAVE_BFD_DISASM)
+ if(STATIC_LINKING)