summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-23 00:13:14 +0000
committerSam James <sam@gentoo.org>2022-11-23 00:29:08 +0000
commitf28a75cf5d8f637bfa798c72c64eaa964909cc28 (patch)
tree2ae92346400c60b8e59067fd9151c61c2eba4343 /dev-tcltk/snack
parentdev-tcltk/tclx: add link to additional upstream bug (diff)
downloadgentoo-f28a75cf5d8f637bfa798c72c64eaa964909cc28.tar.gz
gentoo-f28a75cf5d8f637bfa798c72c64eaa964909cc28.tar.bz2
gentoo-f28a75cf5d8f637bfa798c72c64eaa964909cc28.zip
dev-tcltk/snack: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tcltk/snack')
-rw-r--r--dev-tcltk/snack/files/snack-2.2.10-configure-clang16.patch12
-rw-r--r--dev-tcltk/snack/snack-2.2.10-r10.ebuild (renamed from dev-tcltk/snack/snack-2.2.10-r9.ebuild)6
2 files changed, 17 insertions, 1 deletions
diff --git a/dev-tcltk/snack/files/snack-2.2.10-configure-clang16.patch b/dev-tcltk/snack/files/snack-2.2.10-configure-clang16.patch
new file mode 100644
index 000000000000..e038bf570abf
--- /dev/null
+++ b/dev-tcltk/snack/files/snack-2.2.10-configure-clang16.patch
@@ -0,0 +1,12 @@
+Issue in autoconf which is already fixed upstream but we can't autoreconf,
+it seems.
+--- a/unix/configure
++++ b/unix/configure
+@@ -2928,6 +2928,7 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ #include <ctype.h>
++#include <stdlib.h>
+ #if ((' ' & 0x0FF) == 0x020)
+ # define ISLOWER(c) ('a' <= (c) && (c) <= 'z')
+ # define TOUPPER(c) (ISLOWER(c) ? 'A' + ((c) - 'a') : (c))
diff --git a/dev-tcltk/snack/snack-2.2.10-r9.ebuild b/dev-tcltk/snack/snack-2.2.10-r10.ebuild
index d95bd49e31da..4bed77e60cd6 100644
--- a/dev-tcltk/snack/snack-2.2.10-r9.ebuild
+++ b/dev-tcltk/snack/snack-2.2.10-r10.ebuild
@@ -6,7 +6,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9,10} )
DISTUTILS_OPTIONAL=yes
-inherit distutils-r1 toolchain-funcs virtualx
+inherit distutils-r1 flag-o-matic toolchain-funcs virtualx
DESCRIPTION="The Snack Sound Toolkit (Tcl)"
HOMEPAGE="http://www.speech.kth.se/snack/"
@@ -38,6 +38,7 @@ PATCHES=(
"${FILESDIR}"/${PN}${PV}-seektell-fix.patch
"${FILESDIR}"/tcl-${P}-python3.patch
"${FILESDIR}"/${P}-lto.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
)
HTML_DOCS="${WORKDIR}/${PN}${PV}/doc/*"
@@ -66,6 +67,9 @@ src_prepare() {
}
src_configure() {
+ # For Clang 16, bunch of -Wimplicit-int, etc
+ append-flags -std=gnu89
+
local myconf=""
use alsa && myconf+=" --enable-alsa"