summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-22 07:30:19 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-22 07:30:33 +0200
commitd1c1d0d8ba5d63b8b6a150599ba882e1e9b6c574 (patch)
tree0219549a3e4b8ccee2b29e60bcfa789e054d2992 /dev-ruby
parentdev-ruby/puppet_forge: add 5.0.4 (diff)
downloadgentoo-d1c1d0d8ba5d63b8b6a150599ba882e1e9b6c574.tar.gz
gentoo-d1c1d0d8ba5d63b8b6a150599ba882e1e9b6c574.tar.bz2
gentoo-d1c1d0d8ba5d63b8b6a150599ba882e1e9b6c574.zip
dev-ruby/puppet_forge: drop 5.0.1-r1, 5.0.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppet_forge/Manifest2
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild37
-rw-r--r--dev-ruby/puppet_forge/puppet_forge-5.0.2.ebuild37
3 files changed, 0 insertions, 76 deletions
diff --git a/dev-ruby/puppet_forge/Manifest b/dev-ruby/puppet_forge/Manifest
index 17cd9a7998bd..0d884db51545 100644
--- a/dev-ruby/puppet_forge/Manifest
+++ b/dev-ruby/puppet_forge/Manifest
@@ -1,4 +1,2 @@
-DIST puppet_forge-5.0.1.gem 774144 BLAKE2B 2770c0609d93b3518017b36344025dbd7ab51360fea4af8f7ee610f4117f31de25698ad192ab00755564f0a57d9e6b041a7568440dbc5b47e2830a8cb00cd8f8 SHA512 3d29c166e1c22d7b4d45251866fbd8e6756a3026be5e17b1abe8cd6baaa7af4ddde7f2d07b75c21c5716c545cc6df82e36b1070a43a3d3c363214d3a5102843b
-DIST puppet_forge-5.0.2.gem 774144 BLAKE2B 6b01872246dc4791f78cefcb9df213df5768df483c8fac4bad12ddf358210ecb2b827ad129790e37d636ce4d7d0abb381097ffd2ee518a8472b067f5ba6de0a5 SHA512 861ac99a3e5234a8555fe37329b621135140d41c0fbad69648f56b901b10254d0474494c64525ebc4a0b730dfa91e9889ea4cf6ca7e2d5e40453221dd2e7370d
DIST puppet_forge-5.0.3.gem 776704 BLAKE2B 2ea9e6a17fb5231629551b4dc2ca02f4843d67ded114f43a9891dba6a7ce03ab0b1b8ed38b434e8bcdfc73e940a263964a8254ba18493a137bd14600c3251a18 SHA512 17cb9aaf9c911608b90f2eb3e2561d94bffdfec559cb22bb0fa53d799f4a53f77c332ec261270135a924a4996d35b39945a4a94f7163b44dd9bb10f6ea72366f
DIST puppet_forge-5.0.4.gem 776704 BLAKE2B 5b9969ad88f279d1fac639ae28ed1202dc3daf3ab6c07caa60144080e54bf2d075a88381877c97e71e44df520c04780fdec8096ef896685c938ba399851b3ced SHA512 95c90d79b5c3b7c9f3e3775782357550c69599d7134c599daf1bb81d37e26d32ade7e065f6fe45e97dc535d7755ea3ae302025cc475c95dfb0d98af6ff8efd54
diff --git a/dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild b/dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild
deleted file mode 100644
index dc80c18aca40..000000000000
--- a/dev-ruby/puppet_forge/puppet_forge-5.0.1-r1.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
-HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
-
-LICENSE="Apache-2.0"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/${P}-typhoeus.patch" )
-
-ruby_add_rdepend "
- dev-ruby/faraday:2
- >=dev-ruby/faraday-follow_redirects-0.3.0:0.3
- dev-ruby/minitar
- =dev-ruby/semantic_puppet-1*
-"
-
-all_ruby_prepare() {
- # Avoid integration and user specs since they all require network access
- rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
-
- sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}
diff --git a/dev-ruby/puppet_forge/puppet_forge-5.0.2.ebuild b/dev-ruby/puppet_forge/puppet_forge-5.0.2.ebuild
deleted file mode 100644
index 642b012de688..000000000000
--- a/dev-ruby/puppet_forge/puppet_forge-5.0.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Tools to access Forge API information on Modules, Users, and Releases"
-HOMEPAGE="https://github.com/puppetlabs/forge-ruby"
-
-LICENSE="Apache-2.0"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~amd64"
-IUSE=""
-
-PATCHES=( "${FILESDIR}/${PN}-5.0.1-typhoeus.patch" )
-
-ruby_add_rdepend "
- dev-ruby/faraday:2
- >=dev-ruby/faraday-follow_redirects-0.3.0:0.3
- dev-ruby/minitar
- =dev-ruby/semantic_puppet-1*
-"
-
-all_ruby_prepare() {
- # Avoid integration and user specs since they all require network access
- rm -rf spec/integration spec/unit/forge/v3/user_spec.rb || die
-
- sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
-}