summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-03-15 07:13:42 +0100
committerHans de Graaff <graaff@gentoo.org>2021-03-15 07:13:42 +0100
commit827a630c443212ec84d24e0cf9687f1c30a7b058 (patch)
tree9c2e39019a5ffb1e5f40eab25f08082eb40e26a3 /dev-ruby
parentdev-ruby/liquid: add 5.0.0 (diff)
downloadgentoo-827a630c443212ec84d24e0cf9687f1c30a7b058.tar.gz
gentoo-827a630c443212ec84d24e0cf9687f1c30a7b058.tar.bz2
gentoo-827a630c443212ec84d24e0cf9687f1c30a7b058.zip
dev-ruby/thor: add 1.1.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/thor/Manifest1
-rw-r--r--dev-ruby/thor/thor-1.1.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-ruby/thor/Manifest b/dev-ruby/thor/Manifest
index ad8153d09fed..e774fe07ba47 100644
--- a/dev-ruby/thor/Manifest
+++ b/dev-ruby/thor/Manifest
@@ -1,2 +1,3 @@
DIST thor-git-0.20.3.tgz 94786 BLAKE2B a27ef27d9d375c1f5ab1b065f6ee5b635dab3b43cac7915ae24771e7a9e24189b8c3df8936bf6ad333f0660e4e36ff73372746afc227972f1745dc993b90c85f SHA512 368cedd9584fcdecf8f5feb9b727aa283b37747e8200f8629aaa762f8e3a59dafe6ee1e7c60ef2b43b2a16b319842b10d0f3face12ba8dded4b6211640db7f44
DIST thor-git-1.0.1.tgz 96670 BLAKE2B db7e10a31e7de14441f26e3b5f1574200a3e7f86475ee68e6a18800c6894a5a949c156d54c2be44c1a4a79136a6d93f2416ac616aa77b296997f6b518c101799 SHA512 cd0c6e3833976b27f9d23d69f261d4457ab99bb52eb5e7121b92c53aedd6bd953616215ba01b8b931c86e9cd22b944415810230d0e868c95dc9ef712f05f99d3
+DIST thor-git-1.1.0.tgz 98252 BLAKE2B 1537cfe6e7cc0d92cc8bde56f0e2acf06b6ee4cb366a5686bb62de43dd15709a4aeaf1b30c3dfa71a6d6c7570e702deeebab6da324204388ac427337514be3f0 SHA512 d1872a834478c5a2054dde6f55e93f6765fd628536f99f888bd7495436c88658537d48c44ef1e5ad6d1388edfa294ea2a3f3cbde32c19b7d2253b78bc62bf9d0
diff --git a/dev-ruby/thor/thor-1.1.0.ebuild b/dev-ruby/thor/thor-1.1.0.ebuild
new file mode 100644
index 000000000000..b14819b6a86b
--- /dev/null
+++ b/dev-ruby/thor/thor-1.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_BINWRAP="thor"
+
+RUBY_FAKEGEM_GEMSPEC="thor.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A scripting framework that replaces rake and sake"
+HOMEPAGE="http://whatisthor.com/"
+
+SRC_URI="https://github.com/erikhuda/${PN}/archive/v${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="doc"
+
+USE_RUBY="ruby25 ruby26 ruby27" ruby_add_bdepend "
+ test? (
+ dev-ruby/childlabor
+ dev-ruby/webmock
+ )"
+
+RDEPEND+=" !<dev-ruby/thor-0.20.3-r1:0"
+
+all_ruby_prepare() {
+ # Remove rspec default options (as we might not have the last
+ # rspec).
+ rm .rspec || die
+
+ # Remove Bundler
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Thorfile || die
+
+ # Remove mandatory coverage collection using simplecov which is not
+ # packaged.
+ sed -i -e '/require .simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+
+ # Avoid a spec that requires UTF-8 support, so LANG=C still works,
+ # bug 430402
+ sed -i -e '/uses maximum terminal width/,/end/ s:^:#:' spec/shell/basic_spec.rb || die
+
+ # Avoid currently broken readline specs (already fixed upstream)
+ rm -f spec/line_editor/readline_spec.rb spec/line_editor_spec.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *ruby30)
+ einfo "Skipping tests due to circular dependencies"
+ ;;
+ *)
+ RSPEC_VERSION=3 ruby-ng_rspec spec || die
+ ;;
+ esac
+}