summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-24 09:18:03 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-24 09:18:03 +0200
commit7521bd263d0c539f793c6db43f15c7d5f16f91f7 (patch)
treea03da3b3c1052650a171bacba852a03ab329601f /dev-ruby
parentdev-ruby/actionmailer: add 7.1.4 (diff)
downloadgentoo-7521bd263d0c539f793c6db43f15c7d5f16f91f7.tar.gz
gentoo-7521bd263d0c539f793c6db43f15c7d5f16f91f7.tar.bz2
gentoo-7521bd263d0c539f793c6db43f15c7d5f16f91f7.zip
dev-ruby/activestorage: add 7.1.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activestorage/Manifest1
-rw-r--r--dev-ruby/activestorage/activestorage-7.1.4.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-ruby/activestorage/Manifest b/dev-ruby/activestorage/Manifest
index 07f91732212c..211fe49c76dd 100644
--- a/dev-ruby/activestorage/Manifest
+++ b/dev-ruby/activestorage/Manifest
@@ -4,3 +4,4 @@ DIST rails-7.0.8.3.tgz 11080686 BLAKE2B 2d13559e7b7ab752af4fee480ee51f73b4d1f392
DIST rails-7.0.8.4.tgz 11082427 BLAKE2B 2ca521ad92b7a33fa2160b4cfbc1aac826641d2aac7a8751b6acaed1b7fc42bb860b4ade3f973eb51dc17d20fa4c97b02e8d6b970ae63b042cd58ab2f6cfc797 SHA512 e6628e901fcdcd4b9101cdae0cd556569fc7b577466a15f99d1e221c1c0059287dce87c1362df8b23ded992e96c551b35c0c789e683f080079e678555b7a79e6
DIST rails-7.1.3.3.tgz 10905515 BLAKE2B b2be6d8922d15478136875ac80d65fdc54bdf4a03ec17cddc20c20ae847f08fd52a2b1110ed27feb0217f4aa8dd827a8d95847e32eceaf8f5979843312f12a2a SHA512 0d108654a9ab2a9321822742906c4848508e0e4e09600c01bd5a86deeb324540bbae520a954499c4cc83bfe1246f929a581d1667f2b50c463d0bf8187f603df9
DIST rails-7.1.3.4.tgz 10917333 BLAKE2B 3266de2a86f8b107b18117c06115db14791bb98d672403eff28673e9d98df5e2c9a6c30f72d4141cd1f051054f2d5e1f636a93de9b14114cefef384fded7942a SHA512 4c303be256707b5bbedc05bf5bac7c60ff03cb8a14fa3d709a495d07ad1745d6c6f4d5dceb9860afff46f95f3f9fc525d1bcb75894a5b31a9d35f1aa6b105c5e
+DIST rails-7.1.4.tgz 10926853 BLAKE2B e1e62f95453fa0137337f40291614265ae4d8e6bedf496e0402f160ce938418760dcd850c37e82a7c9dd530dfe442b0f9b22d122dc80f1ff61c5c76244999416 SHA512 67770018663d930cb710fb08358c7d9c9d391a4c721212c55b60c4827f8cbdb38e55ee551b598e93244beba18f9c4c21dfdf6000e67880ac95345a70ff2e0841
diff --git a/dev-ruby/activestorage/activestorage-7.1.4.ebuild b/dev-ruby/activestorage/activestorage-7.1.4.ebuild
new file mode 100644
index 000000000000..06e227f4428b
--- /dev/null
+++ b/dev-ruby/activestorage/activestorage-7.1.4.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="activestorage.gemspec"
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config db"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Attach cloud and local files in Rails applications"
+HOMEPAGE="https://github.com/rails/rails"
+SRC_URI="https://github.com/rails/rails/archive/v${PV}.tar.gz -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+RUBY_S="rails-${PV}/${PN}"
+
+DEPEND+=" test? ( >=app-text/mupdf-1.23.7 media-gfx/imagemagick[jpeg,png,tiff] media-video/ffmpeg app-text/poppler[utils] ) "
+
+ruby_add_rdepend "
+ ~dev-ruby/actionpack-${PV}:*
+ ~dev-ruby/activejob-${PV}:*
+ ~dev-ruby/activerecord-${PV}:*
+ ~dev-ruby/activesupport-${PV}:*
+ dev-ruby/marcel:1.0
+"
+
+ruby_add_bdepend "
+ test? (
+ ~dev-ruby/railties-${PV}
+ >=dev-ruby/image_processing-1.2:0
+ dev-ruby/minitest:5
+ dev-ruby/mini_magick
+ dev-ruby/mocha
+ dev-ruby/rake
+ dev-ruby/sprockets-rails
+ >=dev-ruby/sqlite3-1.6.6
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -e "/\(system_timer\|sdoc\|w3c_validators\|pg\|execjs\|jquery-rails\|'mysql'\|journey\|ruby-prof\|stackprof\|benchmark-ips\|kindlerb\|turbolinks\|coffee-rails\|debugger\|redcarpet\|bcrypt\|uglifier\|aws-sdk-s3\|aws-sdk-sns\|google-cloud-storage\|azure-storage\|blade\|bootsnap\|hiredis\|qunit-selenium\|chromedriver-helper\|redis\|rb-inotify\|stackprof\|websocket-client-simple\|libxml-ruby\|sass-rails\|capybara\|rack-cache\|selenium\|dalli\|listen\|connection_pool\|puma\|mysql2\|webdrivers\|webpacker\|rexml\|webmock\|webrick\|propshaft\|sprockets-export\|rack-test\|terser\|cookiejar\|cgi\|web-console\|trilogy\|error_highlight\|jbuilder\)/ s:^:#:" \
+ -e '/stimulus-rails/,/tailwindcss-rails/ s:^:#:' \
+ -e '/group :\(doc\|job\|lint\|mdl\|rubocop\|test\)/,/^end/ s:^:#:' \
+ -e '/sqlite/ s/1.6.4/99/' \
+ -i ../Gemfile || die
+ rm ../Gemfile.lock || die
+
+ # Use mini_magick since vips is not packaged on Gentoo
+ sed -i -e '/mini_magick/aActiveStorage.variant_processor = :mini_magick' test/test_helper.rb || die
+ # Avoid vips-specific tests
+ sed -e '/\(resized and monochrome variation of JPEG blob\|monochrome with default variant_processor\|disabled variation of JPEG blob\)/askip "No vips support"' \
+ -i test/models/variant_test.rb || die
+
+ # Avoid test where different ffmpeg versions apply different rounding for the duration.
+ sed -i -e '/1.022000/ s:^:#:' test/analyzer/video_analyzer_test.rb || die
+
+ # Avoid failing test depending on yarn
+ rm -f test/javascript_package_test.rb || die
+}