summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-06-15 00:27:40 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-22 17:33:10 -0400
commit23f46cf57e1816cc641f2a94851e82d1282ab8a1 (patch)
tree8de63000a765e23c023288bd479d4385831c89bd /dev-ruby
parentdev-ruby/async: new package, add 1.30.1 and 2.0.2 (diff)
downloadgentoo-23f46cf57e1816cc641f2a94851e82d1282ab8a1.tar.gz
gentoo-23f46cf57e1816cc641f2a94851e82d1282ab8a1.tar.bz2
gentoo-23f46cf57e1816cc641f2a94851e82d1282ab8a1.zip
dev-ruby/console: new package, add 1.15.3
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/console/Manifest1
-rw-r--r--dev-ruby/console/console-1.15.3.ebuild28
-rw-r--r--dev-ruby/console/metadata.xml11
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/console/Manifest b/dev-ruby/console/Manifest
new file mode 100644
index 000000000000..694623a35a8b
--- /dev/null
+++ b/dev-ruby/console/Manifest
@@ -0,0 +1 @@
+DIST console-1.15.3.tar.gz 23089 BLAKE2B 8387b0dc8ee84df3ce930ef79fcfec9e9b947b946770535beeb16fe58496c30134862b6a3fb48a842b321ab2ec493b1e4f9ec3462bdce04aa35066672ee55699 SHA512 c1d7fc987f3f6df3506c85c64d3c93b3eae6b5eca64ac7de2cf7cc0cb5572c102ebd6909d993d9d683081063ff8b7f2de46fefa255491adc47b88f13ff24ea67
diff --git a/dev-ruby/console/console-1.15.3.ebuild b/dev-ruby/console/console-1.15.3.ebuild
new file mode 100644
index 000000000000..f6370717fffc
--- /dev/null
+++ b/dev-ruby/console/console-1.15.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="Beautiful logging for Ruby"
+HOMEPAGE="https://github.com/socketry/console"
+SRC_URI="https://github.com/socketry/console/archive/fc6ecb94bc02b8b75003fc31f0a8b3e1e43cafcf.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+RUBY_S="${PN}-fc6ecb94bc02b8b75003fc31f0a8b3e1e43cafcf"
+
+ruby_add_rdepend "dev-ruby/fiber-local"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ rm -f "gems.rb" || die
+ sed -i -E 's/require '"'"'covered\/rspec'"'"'//g' "spec/spec_helper.rb" || die
+}
diff --git a/dev-ruby/console/metadata.xml b/dev-ruby/console/metadata.xml
new file mode 100644
index 000000000000..eaf87044f48c
--- /dev/null
+++ b/dev-ruby/console/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">socketry/console</remote-id>
+ </upstream>
+</pkgmetadata>