summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/xml-simple
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/xml-simple')
-rw-r--r--dev-ruby/xml-simple/Manifest3
-rw-r--r--dev-ruby/xml-simple/metadata.xml8
-rw-r--r--dev-ruby/xml-simple/xml-simple-1.1.3.ebuild20
-rw-r--r--dev-ruby/xml-simple/xml-simple-1.1.4.ebuild20
-rw-r--r--dev-ruby/xml-simple/xml-simple-1.1.5.ebuild27
5 files changed, 78 insertions, 0 deletions
diff --git a/dev-ruby/xml-simple/Manifest b/dev-ruby/xml-simple/Manifest
new file mode 100644
index 000000000000..6a47dce93c7d
--- /dev/null
+++ b/dev-ruby/xml-simple/Manifest
@@ -0,0 +1,3 @@
+DIST xml-simple-1.1.3.gem 11776 SHA256 acf399ebf7585480868e241dda40314b3fe37063a871b7066e771688943c58c5 SHA512 321eba774f85f45914b98c53cba2cffdeb0725e602145a84bf5d21f72eb0a2033612410b07eee5de9777817403630c8b1c2e0cfc421429b2b34bfaa492b624ad WHIRLPOOL b5222c821c68e331dac1882df54ecae48fe36febdcacf6533bb37506e7d75915666abcb47cf01086a06f62ba8f22e325a46154ee990720c066c3ce09907a2b0c
+DIST xml-simple-1.1.4.gem 11776 SHA256 dabc3f159942450dc932b748b88c1d9603d9572a26108cf187084205711dac74 SHA512 0363adde2f11b7b10b335fa7bea349f1adf00aa09659e394a8bf4685e2dd37318760805435dc8b2372ba15762d5fe44031b9082201df87543a3a8311841d8c69 WHIRLPOOL ccfbb77a900727d6a62ac5cda0ef4fa52bcab31dd1211feaf6c6e9282a43073355d794ad8582860c3e38a4d1554b434d310aa2d28d9896eaf7d666bca86c9e25
+DIST xml-simple-1.1.5.tar.gz 126288 SHA256 e0d4602bea9fcff1bec440fdb8bd4ce27f4003899a60ac62a217a495038e62c4 SHA512 df81a05a0c32141cb5a0328fb782292438ec3ad6037c150e2ff4fee07b65ba9a739987f25f28c196ff8565af53c62120c3a729820a94dd3da0551fe43948f9a3 WHIRLPOOL 570bda1a0fc083601585fec646f3ca0158fa7d740fbc47adc936f5101fec3a6f1b4f6720fb1f41680d541fdf4051175c2d0a3bf881f27a36360dbacc33b0a846
diff --git a/dev-ruby/xml-simple/metadata.xml b/dev-ruby/xml-simple/metadata.xml
new file mode 100644
index 000000000000..e70310e01984
--- /dev/null
+++ b/dev-ruby/xml-simple/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">maik/xml-simple</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/xml-simple/xml-simple-1.1.3.ebuild b/dev-ruby/xml-simple/xml-simple-1.1.3.ebuild
new file mode 100644
index 000000000000..8d28030b94e4
--- /dev/null
+++ b/dev-ruby/xml-simple/xml-simple-1.1.3.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+# Gem only contains lib code, and github repository has no tags.
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Easy API to maintain XML. It is a Ruby port of Grant McLean's Perl module XML::Simple"
+HOMEPAGE="https://github.com/maik/xml-simple"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE=""
diff --git a/dev-ruby/xml-simple/xml-simple-1.1.4.ebuild b/dev-ruby/xml-simple/xml-simple-1.1.4.ebuild
new file mode 100644
index 000000000000..5a09d11d90f6
--- /dev/null
+++ b/dev-ruby/xml-simple/xml-simple-1.1.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# Gem only contains lib code, and github repository has no tags.
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Easy API to maintain XML. It is a Ruby port of Grant McLean's Perl module XML::Simple"
+HOMEPAGE="https://github.com/maik/xml-simple"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
diff --git a/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
new file mode 100644
index 000000000000..ae8af5c52590
--- /dev/null
+++ b/dev-ruby/xml-simple/xml-simple-1.1.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# Gem only contains lib code, and github repository has no tags.
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+SRC_URI="https://github.com/maik/xml-simple/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="Easy API to maintain XML. It is a Ruby port of Grant McLean's Perl module XML::Simple"
+HOMEPAGE="https://github.com/maik/xml-simple"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+each_ruby_test() {
+ cd test || die
+ for i in *.rb; do
+ ${RUBY} -I../lib ${i} || die
+ done
+}