summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-24 10:19:00 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-24 11:25:23 +0100
commite036c94f7edc6234e358a9394fd8043a43c7b683 (patch)
tree3558f03837a0c63f63e2ca17d835caafcc39cf2f /dev-ruby/sigar
parentdev-ruby/open4: EAPI 8 (diff)
downloadgentoo-e036c94f7edc6234e358a9394fd8043a43c7b683.tar.gz
gentoo-e036c94f7edc6234e358a9394fd8043a43c7b683.tar.bz2
gentoo-e036c94f7edc6234e358a9394fd8043a43c7b683.zip
dev-ruby/sigar: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/sigar')
-rw-r--r--dev-ruby/sigar/sigar-0.7.3.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/sigar/sigar-0.7.3.ebuild b/dev-ruby/sigar/sigar-0.7.3.ebuild
deleted file mode 100644
index 3b8f234f356f..000000000000
--- a/dev-ruby/sigar/sigar-0.7.3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="System Information Gatherer And Reporter"
-HOMEPAGE="http://sigar.hyperic.com/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND+=" || ( <sys-libs/glibc-2.26 net-libs/libtirpc )"
-
-all_ruby_prepare() {
- sed -i -e '25i$CFLAGS += " -std=gnu89 -I/usr/include/tirpc"' \
- -e '25i$LDFLAGS += " -ltirpc"' bindings/ruby/extconf.rb || die
-
- # Fix compatibility with glibc 2.25
- sed -i -e '26i#include <sys/sysmacros.h>' \
- -e '27i#include <ctype.h>' bindings/ruby/rbsigar.c src/os/linux/linux_sigar.c || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cbindings/ruby extconf.rb || die
-}
-
-each_ruby_compile() {
- emake -Cbindings/ruby V=1
- mkdir lib || die
- cp bindings/ruby/${PN}$(get_modname) lib/ || die
-}