summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-10-31 02:18:20 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-10-31 02:18:20 +0100
commite6c99c61d30dc04290d5ebf3652fa378c84c3d78 (patch)
treee2a270b123cac211803046af1def10daa084ae0f /dev-ruby/sawyer
parentmedia-sound/yoshimi: version bump to 1.4.1 (diff)
downloadgentoo-e6c99c61d30dc04290d5ebf3652fa378c84c3d78.tar.gz
gentoo-e6c99c61d30dc04290d5ebf3652fa378c84c3d78.tar.bz2
gentoo-e6c99c61d30dc04290d5ebf3652fa378c84c3d78.zip
dev-ruby/sawyer: Add ruby23, drop x86
Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-ruby/sawyer')
-rw-r--r--dev-ruby/sawyer/sawyer-0.7.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/sawyer/sawyer-0.7.0-r1.ebuild b/dev-ruby/sawyer/sawyer-0.7.0-r1.ebuild
new file mode 100644
index 000000000000..6b1d81e648c8
--- /dev/null
+++ b/dev-ruby/sawyer/sawyer-0.7.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Secret User Agent of HTTP"
+HOMEPAGE="https://github.com/lostisland/sawyer"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/faraday-0.10
+ <dev-ruby/addressable-2.5"
+
+all_ruby_prepare() {
+ # Avoid tests that require network acces
+ sed -i -e '/test_blank_response_doesnt_raise/,/^ end/ s:^:#:' test/agent_test.rb || die
+}