summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-05-25 07:10:00 +0200
committerHans de Graaff <graaff@gentoo.org>2020-05-25 07:22:20 +0200
commit6222564caf3767649876194249a7f2442d03fa99 (patch)
tree33790bee1f3ea3e119b9a12afd33f97400ef2e5a /dev-ruby/rinku
parentdev-ruby/rinku: cleanup (diff)
downloadgentoo-6222564caf3767649876194249a7f2442d03fa99.tar.gz
gentoo-6222564caf3767649876194249a7f2442d03fa99.tar.bz2
gentoo-6222564caf3767649876194249a7f2442d03fa99.zip
dev-ruby/rinku: avoid dependency on bundler
Closes: https://bugs.gentoo.org/723892 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rinku')
-rw-r--r--dev-ruby/rinku/rinku-2.0.6.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ruby/rinku/rinku-2.0.6.ebuild b/dev-ruby/rinku/rinku-2.0.6.ebuild
index 22158d3edb46..56f0c9f60e36 100644
--- a/dev-ruby/rinku/rinku-2.0.6.ebuild
+++ b/dev-ruby/rinku/rinku-2.0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,6 +17,10 @@ SLOT="0"
KEYWORDS="~amd64"
IUSE=""
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' test/autolink_test.rb || die
+}
+
each_ruby_configure() {
${RUBY} -Cext/${PN} extconf.rb || die
}