summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-02-11 06:25:06 +0100
committerHans de Graaff <graaff@gentoo.org>2019-02-11 06:25:06 +0100
commit4ec95a007825e8c666f40324ab05aa991b8b032a (patch)
tree7e61303d8474c7dc86651d09c1864b88132962d0 /dev-ruby/rinku/rinku-2.0.5.ebuild
parentdev-ruby/exifr: add 1.3.6 (diff)
downloadgentoo-4ec95a007825e8c666f40324ab05aa991b8b032a.tar.gz
gentoo-4ec95a007825e8c666f40324ab05aa991b8b032a.tar.bz2
gentoo-4ec95a007825e8c666f40324ab05aa991b8b032a.zip
dev-ruby/rinku: add 2.0.5
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/rinku/rinku-2.0.5.ebuild')
-rw-r--r--dev-ruby/rinku/rinku-2.0.5.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/rinku/rinku-2.0.5.ebuild b/dev-ruby/rinku/rinku-2.0.5.ebuild
new file mode 100644
index 000000000000..7731dbfffa0c
--- /dev/null
+++ b/dev-ruby/rinku/rinku-2.0.5.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.markdown"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby library that does autolinking"
+HOMEPAGE="https://github.com/vmg/rinku"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/${PN} extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/${PN}
+ cp ext/${PN}/${PN}$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/autolink_test.rb || die
+}