summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-07 09:52:12 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-07 09:52:12 +0200
commitd03a112a01cbfce68f08e90e62f71a8f00d0266a (patch)
treecea001d0ffed865776378edd675677d62bdf6ff0 /dev-ruby/jwt
parentdev-ruby/oauth2: drop 1.4.7 (diff)
downloadgentoo-d03a112a01cbfce68f08e90e62f71a8f00d0266a.tar.gz
gentoo-d03a112a01cbfce68f08e90e62f71a8f00d0266a.tar.bz2
gentoo-d03a112a01cbfce68f08e90e62f71a8f00d0266a.zip
Revert "dev-ruby/jwt: drop 2.2.3"
This reverts commit 174622937801181221d49c23270cb2e77a0628b1. Like last time this is still used by r10k. Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/jwt')
-rw-r--r--dev-ruby/jwt/Manifest1
-rw-r--r--dev-ruby/jwt/jwt-2.2.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/jwt/Manifest b/dev-ruby/jwt/Manifest
index 851fae32fa37..45caf959d6e6 100644
--- a/dev-ruby/jwt/Manifest
+++ b/dev-ruby/jwt/Manifest
@@ -1 +1,2 @@
+DIST jwt-2.2.3.tar.gz 50675 BLAKE2B 904a2b9be80ece10cc046d35df784ecc4991c3b09a79c2e2e461003596e9212409ed5840282ce632d3ff499754c505cd899ca95945f562883869ff3c50c4399a SHA512 ebefbf8f825afc1a78329088012118ed681a61bdf9e1c6a3fa125d46105092f1f26a4bc88791788c0290009dbc0427128d655a301c034ac07caf14216744962c
DIST jwt-2.7.0.tar.gz 75020 BLAKE2B 2bfa009912f4037dc13672ef6d43557e70bc9a06d399d949a6c5ddee641dc550a218242482ec0a66eb470ab117d1e192dd1ca6fdb5a03926d85f4902d72500e7 SHA512 8e0bb9909d123b7b73fe01fafc4088e45140e417b1bff84b240a317f3dca8085b2b987bd1e93cb1506efc66a1f7371168f8202a590308ee0e4c52820983a9789
diff --git a/dev-ruby/jwt/jwt-2.2.3.ebuild b/dev-ruby/jwt/jwt-2.2.3.ebuild
new file mode 100644
index 000000000000..bed4ee7f5a63
--- /dev/null
+++ b/dev-ruby/jwt/jwt-2.2.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-jwt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby implementation of JSON Web Token draft 06"
+HOMEPAGE="https://github.com/jwt/ruby-jwt"
+SRC_URI="https://github.com/jwt/ruby-jwt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RUBY_S="ruby-jwt-${PV}"
+
+PATCHES=( "${FILESDIR}/${P}-ec-test.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rbnacl )"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/ s:^:#:" \
+ -e '/^SimpleCov.start/,/^end/ s:^:#:' \
+ spec/spec_helper.rb || die
+
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}