summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-25 07:48:23 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-25 08:11:21 +0200
commitf8f3b4ab64c930480559343df4a329b3172007b6 (patch)
treec012c7b452998023f2a5accd76ea9d91867a87bb /dev-ruby/google-protobuf/google-protobuf-3.9.2.ebuild
parentdev-python/cmd2: Bump to 0.9.17 (diff)
downloadgentoo-f8f3b4ab64c930480559343df4a329b3172007b6.tar.gz
gentoo-f8f3b4ab64c930480559343df4a329b3172007b6.tar.bz2
gentoo-f8f3b4ab64c930480559343df4a329b3172007b6.zip
dev-ruby/google-protobuf: add 3.9.2
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/google-protobuf/google-protobuf-3.9.2.ebuild')
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.9.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.9.2.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.9.2.ebuild
new file mode 100644
index 000000000000..749ced3b808c
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( >=dev-libs/protobuf-3.7.0 )"
+
+each_ruby_prepare() {
+ sed -i -e 's:../src/protoc:protoc: ; /^task :build/ s/:compile,//' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}