summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-02 14:53:16 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-02 14:57:48 +0100
commit71b8bb70c5880eefc492c7b6c0f08dc3968c04f4 (patch)
tree2febaf0e588a645cc0fb5e8a4d5a36697bffa83b /dev-ruby/faraday
parentdev-ruby/faraday-net_http_persistent: keyword 2.1.0 for ~arm, ~ppc, ~ppc64, ~x86 (diff)
downloadgentoo-71b8bb70c5880eefc492c7b6c0f08dc3968c04f4.tar.gz
gentoo-71b8bb70c5880eefc492c7b6c0f08dc3968c04f4.tar.bz2
gentoo-71b8bb70c5880eefc492c7b6c0f08dc3968c04f4.zip
dev-ruby/faraday: add 1.4.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/faraday')
-rw-r--r--dev-ruby/faraday/Manifest1
-rw-r--r--dev-ruby/faraday/faraday-1.4.3.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/dev-ruby/faraday/Manifest b/dev-ruby/faraday/Manifest
index c4de14c1e9ff..716596a01b52 100644
--- a/dev-ruby/faraday/Manifest
+++ b/dev-ruby/faraday/Manifest
@@ -1,4 +1,5 @@
DIST faraday-1.3.1.tar.gz 840638 BLAKE2B 284f7f612d3ab791a00ceab823be0246685fa38356bfeb6e01c12e81c7369c500719a6023dd929160ca598b41401b82cda0d8e9e363d0e7bdd91791742f8e68f SHA512 b89839e5d602911904ce009f52d011c124f84811e0676a3a524d22ea7084d99a971b6573dcde6d512bf933909cc461ef01cd82a8eeb9df581c56f17f31966b1b
+DIST faraday-1.4.3.tar.gz 838150 BLAKE2B 324788f73e450d386655e805163ffd6299c6d11453a7b034f55b549d3d4edcf3d2936b732e1e13fe4c38286f09b8c1aec7aa5ca42e2c2d6bd2f841a7b412e822 SHA512 7a7c370715c912434fcca5bae11543d24ef0990d24a8ab069f1bebdb534b8d1a9bc90c9625574e34f0ad9c4543391b24ce134a103ddc40b152ebd65d958c5517
DIST faraday-2.7.10.tar.gz 833034 BLAKE2B dca3ef6a48aa4d14f1717344c5ec85b1e9caf7205eb7ae1be76a7a96bdee9fbef2d112c05f96f5625262d2783fc0e5e196343f67b371e480532c5e74f77b73eb SHA512 e1d2792f49df5679c16d3690a2475c56db9ae537bf53db4bb7cc256b41455d3db36d8d672eaf3f8a63fb2b04349d45dd4d32a2c194606fd795de51b1f79ead85
DIST faraday-2.7.11.tar.gz 1029832 BLAKE2B fd5cc5a9fa0d8c40893600a89f71d906a9de0b800c9723d64e8dad5dac1bff4ec61ba2714347b38beeadafb42a29ed6fb217344ffdb122e137607ff140b6aed7 SHA512 eafbc0c88a94f03bfe659b10a86050d07e79c6c2fc81c16af9e2aad68bc5482748a4a41a0a7828b272a9e034cb77dab06e0a9a0e136a56c72b72ed97e5bad50c
DIST faraday-2.7.12.tar.gz 1029923 BLAKE2B 267880c4d35284c1eb2f894e9c2803662cf5a901417b5a8c6934b8cef3fe842924d945b64b6617dcd017cbfdc3c9be19271c7c295e2c39518215aba3ab8304bb SHA512 e35aaa7096a77a3dc76aa0a2c262d6e83d894564474dd5b1414488615e54096e96fefa245d65804afa71fc22ef55748c18a32213ba6eaedb431246d5f8d382a1
diff --git a/dev-ruby/faraday/faraday-1.4.3.ebuild b/dev-ruby/faraday/faraday-1.4.3.ebuild
new file mode 100644
index 000000000000..37c40778929b
--- /dev/null
+++ b/dev-ruby/faraday/faraday-1.4.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="spec"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HTTP/REST API client library with pluggable components"
+HOMEPAGE="https://github.com/lostisland/faraday"
+SRC_URI="https://github.com/lostisland/faraday/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+DEPEND+=" test? ( sys-process/lsof )"
+
+ruby_add_rdepend "
+ dev-ruby/faraday-net_http_persistent:1
+ dev-ruby/faraday-net_http:1
+ >=dev-ruby/multipart-post-1.2.0 <dev-ruby/multipart-post-3
+ dev-ruby/ruby2_keywords
+"
+ruby_add_bdepend "test? (
+ >=dev-ruby/test-unit-2.4
+ >=dev-ruby/connection_pool-2.2.2
+ >=dev-ruby/patron-0.4.2
+ dev-ruby/rack
+ >=dev-ruby/rack-test-0.6
+ dev-ruby/webmock
+ )"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/d ; 1irequire "yaml"' Rakefile || die
+ sed -i -e '/bundler/,/^fi/ s:^:#:' script/test || die
+ # Avoid loading all lib files since some of them require unpackaged dependencies.
+ sed -e '/[Cc]overall/ s:^:#:' \
+ -e '/lib\/\*\*/ s:^:#:' \
+ -e '/simplecov/ s:^:#:' \
+ -e '/SimpleCov/,/end/ s:^:#:' \
+ -e '/pry/ s:^:#:' \
+ -e '3igem "faraday-net_http", "~> 1.0"; gem "faraday-net_http_persistent", "~> 1.0"' \
+ -i spec/spec_helper.rb || die
+
+ sed -e '/git ls-files/ s:^:#:' \
+ -e "s:_relative ': './:" \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid multipart tests that require an unpackaged dependency
+ # that appears to be no longer maintained.
+ rm -f spec/faraday/request/multipart_spec.rb || die
+ sed -e '/multipart_parser/ s:^:#:' \
+ -i spec/support/helper_methods.rb || die
+
+ # Remove specs for unpackaged adapters
+ rm -f spec/faraday/adapter/{em_http,em_synchrony,excon,httpclient}_spec.rb || die
+
+ # Remove unpackaged adapters. These packages where part of earlier
+ # faraday versions but since we do not package their dependencies
+ # they never worked on a pure Gentoo install. We are taking this
+ # approach so we can add ruby32 compatibility to faraday:1 for
+ # those adapters that we do support.
+ sed -e '/require.*\(em_http\|em_synchrony\|excon\)/ s:^:#:' \
+ -i lib/faraday.rb ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Make this adapter optional since it comes with a long list of
+ # dependencies.
+ if ! has_version "dev-ruby/typhoeus:1" ; then
+ rm -f spec/faraday/adapter/typhoeus_spec.rb || die
+ fi
+
+ # Avoid a spec that gets tripped up by recent rack encoding changes.
+ sed -e '/encodes rack compat/ s/it/xit/' -i spec/faraday/params_encoders/nested_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the test scripts use the right ruby interpreter
+ sed -i -e 's:ruby:'${RUBY}':' script/* || die
+}
+
+each_ruby_test() {
+ MT_NO_PLUGINS=true each_fakegem_test
+
+ # Sleep some time to allow the sinatra test server to die
+ einfo "Waiting for test server to stop"
+ sleep 10
+}