summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-12-20 20:34:56 +0100
committerHans de Graaff <graaff@gentoo.org>2015-12-20 20:34:56 +0100
commitd84814cef434291dd0a8ba2058d8be6b8a1a1670 (patch)
tree846453b8727ef87051bffc1073fb01c4005cb7ae /dev-ruby/ast/ast-2.2.0.ebuild
parentdev-ruby/arel: add 7.0.0 (diff)
downloadgentoo-d84814cef434291dd0a8ba2058d8be6b8a1a1670.tar.gz
gentoo-d84814cef434291dd0a8ba2058d8be6b8a1a1670.tar.bz2
gentoo-d84814cef434291dd0a8ba2058d8be6b8a1a1670.zip
dev-ruby/ast: add 2.2.0
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-ruby/ast/ast-2.2.0.ebuild')
-rw-r--r--dev-ruby/ast/ast-2.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ast/ast-2.2.0.ebuild b/dev-ruby/ast/ast-2.2.0.ebuild
new file mode 100644
index 000000000000..3a9bdbc70df4
--- /dev/null
+++ b/dev-ruby/ast/ast-2.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library for working with abstract syntax trees"
+HOMEPAGE="https://github.com/whitequark/ast"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ dev-ruby/bacon )"
+
+all_ruby_prepare() {
+ sed -i -e "/[Bb]undler/d" Rakefile || die
+ sed -i -e "/git ls/d" ${PN}.gemspec || die
+ sed -i -e "/simplecov/,+11d" -e "/colored_output/d" test/helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S bacon -Itest -a || die
+}