summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:33:10 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commitba260dfbc10f74634aef7949a0b01f94493f2f12 (patch)
tree9a3943a73a720a200f60c20cb48658e7477a66bc /dev-ros/rospy/rospy-1.11.15.ebuild
parentdev-ros/roscpp: Bump to 1.11.15. (diff)
downloadgentoo-ba260dfbc10f74634aef7949a0b01f94493f2f12.tar.gz
gentoo-ba260dfbc10f74634aef7949a0b01f94493f2f12.tar.bz2
gentoo-ba260dfbc10f74634aef7949a0b01f94493f2f12.zip
dev-ros/rospy: Bump to 1.11.15.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/rospy/rospy-1.11.15.ebuild')
-rw-r--r--dev-ros/rospy/rospy-1.11.15.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rospy/rospy-1.11.15.ebuild b/dev-ros/rospy/rospy-1.11.15.ebuild
new file mode 100644
index 000000000000..720ae2de005b
--- /dev/null
+++ b/dev-ros/rospy/rospy-1.11.15.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=clients/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ ros-catkin_src_install
+ # Other tests need these nodes
+ exeinto /usr/share/${PN}
+ doexe test_nodes/*
+}