summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-09-21 12:46:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-09-21 15:47:07 +0200
commit175c5789169ce142f41a85e95f9f5d4f0d70e7b5 (patch)
tree1fea6ca97f4002464ae3ea9c98cfa421d5fd1c26 /dev-ros/rosbridge_library/rosbridge_library-0.11.10.ebuild
parentdev-ros/rosapi: Bump to 0.11.10. (diff)
downloadgentoo-175c5789169ce142f41a85e95f9f5d4f0d70e7b5.tar.gz
gentoo-175c5789169ce142f41a85e95f9f5d4f0d70e7b5.tar.bz2
gentoo-175c5789169ce142f41a85e95f9f5d4f0d70e7b5.zip
dev-ros/rosbridge_library: Bump to 0.11.10.
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosbridge_library/rosbridge_library-0.11.10.ebuild')
-rw-r--r--dev-ros/rosbridge_library/rosbridge_library-0.11.10.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ros/rosbridge_library/rosbridge_library-0.11.10.ebuild b/dev-ros/rosbridge_library/rosbridge_library-0.11.10.ebuild
new file mode 100644
index 000000000000..0e9d84e423a4
--- /dev/null
+++ b/dev-ros/rosbridge_library/rosbridge_library-0.11.10.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Core rosbridge package for parsing JSON and performing the appropriate action"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/roscpp[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rosservice[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/rostopic[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pillow[\${PYTHON_USEDEP}]")
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pymongo[\${PYTHON_USEDEP}]")
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-ros/rostest[${PYTHON_SINGLE_USEDEP}]
+ dev-ros/actionlib_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rospy_tutorials[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/stereo_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ )
+"