summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-15 17:14:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-15 17:35:51 +0200
commit3c74c36c6eb580c141c54181885272d4013f6a6f (patch)
tree900e31e6da3f53a27820390d70caf61ab85468fd /dev-ros/rosapi/rosapi-0.11.9.ebuild
parentdev-ros/rosapi: update live ebuild (diff)
downloadgentoo-3c74c36c6eb580c141c54181885272d4013f6a6f.tar.gz
gentoo-3c74c36c6eb580c141c54181885272d4013f6a6f.tar.bz2
gentoo-3c74c36c6eb580c141c54181885272d4013f6a6f.zip
dev-ros/rosapi: Bump to 0.11.9.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosapi/rosapi-0.11.9.ebuild')
-rw-r--r--dev-ros/rosapi/rosapi-0.11.9.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rosapi/rosapi-0.11.9.ebuild b/dev-ros/rosapi/rosapi-0.11.9.ebuild
new file mode 100644
index 000000000000..ad2e905a26f1
--- /dev/null
+++ b/dev-ros/rosapi/rosapi-0.11.9.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/RobotWebTools/rosbridge_suite"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Service calls for getting ros meta-information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosbridge_library[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"