summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-11-10 09:25:52 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-11-10 09:51:18 +0100
commit55c651ec61d1e80b791e3d9bf2a10f3c50c7891e (patch)
tree29fea90b43d33624d16be3716a830a6913e37a6a /dev-ros/realtime_tools/realtime_tools-1.11.0.ebuild
parentdev-ros/realtime_tools: Remove old (diff)
downloadgentoo-55c651ec61d1e80b791e3d9bf2a10f3c50c7891e.tar.gz
gentoo-55c651ec61d1e80b791e3d9bf2a10f3c50c7891e.tar.bz2
gentoo-55c651ec61d1e80b791e3d9bf2a10f3c50c7891e.zip
dev-ros/realtime_tools: bump to 1.11.0
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'dev-ros/realtime_tools/realtime_tools-1.11.0.ebuild')
-rw-r--r--dev-ros/realtime_tools/realtime_tools-1.11.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/realtime_tools/realtime_tools-1.11.0.ebuild b/dev-ros/realtime_tools/realtime_tools-1.11.0.ebuild
new file mode 100644
index 000000000000..828df6489858
--- /dev/null
+++ b/dev-ros/realtime_tools/realtime_tools-1.11.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-controls/realtime_tools"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Set of tools that can be used from a hard realtime thread, without breaking the realtime behavior"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+"
+DEPEND="${RDEPEND}"