summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 18:36:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 19:34:39 +0200
commit34316adeffae679a81fa80c23fab79a85f37f094 (patch)
tree6b1ea6549beec8cdd22640fee1d0d3c9ed5b9a4a /dev-ros/gmapping
parentgnome-base/gnome-shell: update patchset (diff)
downloadgentoo-34316adeffae679a81fa80c23fab79a85f37f094.tar.gz
gentoo-34316adeffae679a81fa80c23fab79a85f37f094.tar.bz2
gentoo-34316adeffae679a81fa80c23fab79a85f37f094.zip
dev-ros/gmapping: bump to 1.4.1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/gmapping')
-rw-r--r--dev-ros/gmapping/Manifest1
-rw-r--r--dev-ros/gmapping/gmapping-1.4.1.ebuild26
-rw-r--r--dev-ros/gmapping/gmapping-9999.ebuild6
3 files changed, 30 insertions, 3 deletions
diff --git a/dev-ros/gmapping/Manifest b/dev-ros/gmapping/Manifest
index 60b37799cb77..c9751bd869ca 100644
--- a/dev-ros/gmapping/Manifest
+++ b/dev-ros/gmapping/Manifest
@@ -1,2 +1,3 @@
DIST slam_gmapping-1.3.10.tar.gz 21032 BLAKE2B cca0779e64d45622dad4ec29cb3c1d0162176038288c0aa7b117f1a76a7655f3af3024dba7ff1025948e400e0176794a553e357a235187d9196161a635ab6d01 SHA512 fa4485ddc9fcfaac63a63d209a5a994e33e78546a39edcf47eb3c3f1775f0d87a1f562319058868838990bbf85a9515ff0228779dce7531148f208b3522e7e7a
DIST slam_gmapping-1.4.0.tar.gz 21123 BLAKE2B 088d1bfaa69bf98eb2b2176afbfadf843f5f478f9c54dc7eb32fa91116da31bab66f9a1ac09d0535629cc5a7f604d153c90c5a25f173fb867369aa9e33d4d7b2 SHA512 ae7984716113e24e1bced88523729481829303a2b88d247b8fc8bdd23c0f38b4ce6260d7086d79a6653ecfdbe8ba60ae011af20180ffcb5025cd9d347d3e76b1
+DIST slam_gmapping-1.4.1.tar.gz 21258 BLAKE2B 61b6ee8064be43a3f6e1cafba4efb24b9cf9faa471f749539dcf5aaba9a027885f32549f9df465b88cf02a38f7ebca8fdea469880512298ab0ebf221a3e18bfb SHA512 adc458a033ed0c573a1099ff8c8164d5157b5fd94efafa92fc3a45bcde86a0754f582e87743289637c2f6f7632557ac924ed2cf62d89b15f1a47b822773dbdba
diff --git a/dev-ros/gmapping/gmapping-1.4.1.ebuild b/dev-ros/gmapping/gmapping-1.4.1.ebuild
new file mode 100644
index 000000000000..c3d87b4563b2
--- /dev/null
+++ b/dev-ros/gmapping/gmapping-1.4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS wrapper for OpenSlam's Gmapping"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/openslam_gmapping
+ dev-ros/rosbag_storage
+ dev-ros/gmapping
+"
+DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rostest"
diff --git a/dev-ros/gmapping/gmapping-9999.ebuild b/dev-ros/gmapping/gmapping-9999.ebuild
index 307f03f929b1..c3d87b4563b2 100644
--- a/dev-ros/gmapping/gmapping-9999.ebuild
+++ b/dev-ros/gmapping/gmapping-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/slam_gmapping"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
@@ -15,7 +15,6 @@ IUSE=""
RDEPEND="
dev-libs/boost:=
- dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/roscpp
dev-ros/tf
dev-ros/openslam_gmapping
@@ -23,4 +22,5 @@ RDEPEND="
dev-ros/gmapping
"
DEPEND="${RDEPEND}
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/rostest"