summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-28 16:30:11 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:19:50 +0200
commit1ba24c2c00f0b561667a02108c87db55e69951e7 (patch)
treef785ec863124d159600b7195fb962e2592f28b15 /dev-ros/geodesy
parentdev-ros/qt_dotgraph: convert to python-single-r1 (diff)
downloadgentoo-1ba24c2c00f0b561667a02108c87db55e69951e7.tar.gz
gentoo-1ba24c2c00f0b561667a02108c87db55e69951e7.tar.bz2
gentoo-1ba24c2c00f0b561667a02108c87db55e69951e7.zip
dev-ros/geodesy: convert to python-single-r1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/geodesy')
-rw-r--r--dev-ros/geodesy/geodesy-0.5.5.ebuild6
-rw-r--r--dev-ros/geodesy/geodesy-9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-ros/geodesy/geodesy-0.5.5.ebuild b/dev-ros/geodesy/geodesy-0.5.5.ebuild
index 359c415f7f2f..597e80d1d00e 100644
--- a/dev-ros/geodesy/geodesy-0.5.5.ebuild
+++ b/dev-ros/geodesy/geodesy-0.5.5.ebuild
@@ -20,7 +20,7 @@ RDEPEND="
dev-ros/tf
dev-ros/unique_id
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pyproj[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
dev-libs/boost:=
"
DEPEND="${RDEPEND}
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? (
- dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
dev-cpp/gtest
- dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"
diff --git a/dev-ros/geodesy/geodesy-9999.ebuild b/dev-ros/geodesy/geodesy-9999.ebuild
index 359c415f7f2f..597e80d1d00e 100644
--- a/dev-ros/geodesy/geodesy-9999.ebuild
+++ b/dev-ros/geodesy/geodesy-9999.ebuild
@@ -20,7 +20,7 @@ RDEPEND="
dev-ros/tf
dev-ros/unique_id
dev-ros/uuid_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
- dev-python/pyproj[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/pyproj[\${PYTHON_USEDEP}]")
dev-libs/boost:=
"
DEPEND="${RDEPEND}
@@ -28,7 +28,7 @@ DEPEND="${RDEPEND}
dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
test? (
- dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_SINGLE_USEDEP}]
dev-cpp/gtest
- dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
)"