summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-16 14:34:28 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-16 14:36:44 +0100
commit380759627d1e51d217db6d487e8d5d8670c1c0af (patch)
tree85b5ff9f1d2b0042554f8978d8fca1fd9e080d1c /dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
parentdev-ros/gazebo_plugins: bump to 2.7.3 (diff)
downloadgentoo-380759627d1e51d217db6d487e8d5d8670c1c0af.tar.gz
gentoo-380759627d1e51d217db6d487e8d5d8670c1c0af.tar.bz2
gentoo-380759627d1e51d217db6d487e8d5d8670c1c0af.zip
dev-ros/gazebo_ros: bump to 2.7.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild')
-rw-r--r--dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild b/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
new file mode 100644
index 000000000000..ca217b085352
--- /dev/null
+++ b/dev-ros/gazebo_ros/gazebo_ros-2.7.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="ROS plugins that offer message and service publishers for interfacing with gazebo"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-libs/tinyxml
+ sci-electronics/gazebo:=
+ dev-libs/protobuf:=
+ dev-ros/gazebo_plugins[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/tf[${PYTHON_USEDEP}]
+ dev-ros/dynamic_reconfigure
+ dev-libs/libxml2
+ dev-libs/boost:=[threads]
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"