summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 11:27:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 11:39:22 +0200
commitbcaf39c9ac1616d463ba07ea63c1338b18e8a30f (patch)
tree853d29d8149b43e8d917878f03b289c1c2ec6e45 /dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild
parentdev-ros/actionlib_msgs: Initial import. Ebuild by me. (diff)
downloadgentoo-bcaf39c9ac1616d463ba07ea63c1338b18e8a30f.tar.gz
gentoo-bcaf39c9ac1616d463ba07ea63c1338b18e8a30f.tar.bz2
gentoo-bcaf39c9ac1616d463ba07ea63c1338b18e8a30f.zip
dev-ros/diagnostic_msgs: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild')
-rw-r--r--dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild b/dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild
new file mode 100644
index 000000000000..09b1c0e82eda
--- /dev/null
+++ b/dev-ros/diagnostic_msgs/diagnostic_msgs-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/common_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for the diagnostic and runtime monitoring systems in ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"