summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-02 09:52:47 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-02 09:52:47 +0100
commitd825b55d90afbb583a24de11d498d730d749a464 (patch)
tree5e79f494ed84f8a44051ba5620f1965fe002977d /dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
parentdev-ros/urg_node: Initial import. Ebuild by me. (diff)
downloadgentoo-d825b55d90afbb583a24de11d498d730d749a464.tar.gz
gentoo-d825b55d90afbb583a24de11d498d730d749a464.tar.bz2
gentoo-d825b55d90afbb583a24de11d498d730d749a464.zip
dev-ros/depthimage_to_laserscan: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild')
-rw-r--r--dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
new file mode 100644
index 000000000000..98afcc8f62b6
--- /dev/null
+++ b/dev-ros/depthimage_to_laserscan/depthimage_to_laserscan-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/depthimage_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a depth image to a laser scan for use with navigation and localization"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/image_geometry
+ dev-ros/nodelet
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"