summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-07-15 20:55:51 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-07-15 21:01:06 -0400
commit8058fc0bcd8dad16f401225fdb1f8cfe241963b0 (patch)
tree214728011996559e24582ddac470a4ebc07aec50 /dev-qt
parentdev-qt/qtlanguageserver: drop 6.7.1 (diff)
downloadgentoo-8058fc0bcd8dad16f401225fdb1f8cfe241963b0.tar.gz
gentoo-8058fc0bcd8dad16f401225fdb1f8cfe241963b0.tar.bz2
gentoo-8058fc0bcd8dad16f401225fdb1f8cfe241963b0.zip
dev-qt/qtlocation: drop 6.7.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-6.7.1.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index 22c136f17451..c7cba3023acb 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,6 +1,5 @@
DIST qtlocation-5.15.11-patchset.tar.xz 4796 BLAKE2B dcfa75bd3fb2e9069e1a530c27e2b4e9ac921fcf0ccb712f0894375b575ba25103948c6e5b85b56a8f9c9f2d7edf7df8e38501e93356e69f060b577a04c2d221 SHA512 14bd2864abc6f446dc4fbac03548cb42305685b46db757d856360780144095a021130bc0ebf1d07a516dc7991dc0cfbf733bd0ef6be58237bc15822c21af1d0b
DIST qtlocation-everywhere-opensource-src-5.15.14.tar.xz 6549056 BLAKE2B 831c7091a7b9d1355121f7e1e89f62c8aaa8819bef98c80f90b1521eea9c11a35452557c97d1dd49d13e0e810bd70f5038f8682f6ac42b68622cd269664eadd3 SHA512 5a6271d61bb9ede80b8483e784d8cc15170cf3f7b019472b2362c742e1e1fd52d811c2132b751574dacee6f7274b81e6049b8a3dc934ba7612c0aef6643062dd
-DIST qtlocation-everywhere-src-6.7.1.tar.xz 3166636 BLAKE2B 9e42fc72473f9e11aac9de4c79acf69ce406903f2bd2611cad38b803c67bee30a8812a0700bbd4193a6aafd4b4e04ab0dacf4d79eda0bce739a0eb141c742a81 SHA512 6d7c332ff6a974102f874801c90a64d606e3f9db53787029091cfe043c087f7825d983d6245dfa749f46339c1886ecb74dcf0f9638e9d9bde7c9d6047c47d467
DIST qtlocation-everywhere-src-6.7.2.tar.xz 3166188 BLAKE2B ca22bc51308b5f5b28f96bedd4190ad747bd335790ec0975e1dc381d8fdacf720907a9842ec01cdd1add3d56549d4c096021731ea3268423d3288e1b24c993a6 SHA512 d7b8d4b9c99247362747d2d8fcf9207e710bed70c320d5c38e6868760cfe5ae2a158d1c0496af939a3e0d74369a86673cddfb25096ff8dda8dc209fd0df94e21
DIST qtlocation-mapboxgl-5.15.14-35d56672.tar.gz 3726302 BLAKE2B f51c0589a06fab35ba85b3bf4ca8a1904cda5aec47b17fdf747da527d02be623a76b1af5883b33267fab825a4b5d0863ea0220f2907e98e286b40d4a0bbc82e5 SHA512 5c2ff6ab7e4382d87546a802c5603bdcec3deb7fbb836fc981292c67660514caaa6118e164d2e099d0304710035572706562ec84e4aba5ce36b01cade8b0993e
DIST qtlocation-mapboxgl-5.15.14-4c88f2c0.tar.gz 3726387 BLAKE2B e9b818505ace86516262d1407450c14be82122bb91363a57708795844089371ac7d511a857f713c7cb4e6f8b54867aab0bc5dcdb9c49aa28aa3f8363271378e0 SHA512 e4d9133db892fd8b7b1bcf584bf7dae30c0f0353f3b0a696a6cabc9485067f262d42554b583640521734498572e5480b5e8d0143d5be47bb92077f3192fefa4d
diff --git a/dev-qt/qtlocation/qtlocation-6.7.1.ebuild b/dev-qt/qtlocation/qtlocation-6.7.1.ebuild
deleted file mode 100644
index fdafb2309b3a..000000000000
--- a/dev-qt/qtlocation/qtlocation-6.7.1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit qt6-build
-
-DESCRIPTION="Location (places, maps, navigation) library for the Qt6 framework"
-
-if [[ ${QT6_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv x86"
-fi
-
-RDEPEND="
- ~dev-qt/qtbase-${PV}:6[network]
- ~dev-qt/qtdeclarative-${PV}:6
- ~dev-qt/qtpositioning-${PV}:6[qml]
-"
-DEPEND="${RDEPEND}"
-
-CMAKE_SKIP_TESTS=(
- # ignores QML_IMPORT_PATH (unlike other tests) and looks in
- # the missing builddir/qml, skip rather than work around
- tst_declarative_ui
-)
-
-src_install() {
- qt6-build_src_install
-
- if use test; then
- local delete=( # sigh
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*TestGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Location/*UnsupportedPlacesGeoServicePlugin*.cmake
- "${D}${QT6_LIBDIR}"/cmake/Qt6Qml/QmlPlugins/*declarative_location_test*.cmake
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_geocodingplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_placesplugin_unsupported.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_qmltestplugin.so
- "${D}${QT6_PLUGINDIR}"/geoservices/libqtgeoservices_routingplugin.so
- "${D}${QT6_QMLDIR}"/QtLocation/Test
- )
- # using -f given not tracking which tests may be skipped or not
- rm -rf -- "${delete[@]}" || die
- fi
-}