summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-12-05 22:02:10 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-12-05 23:09:43 +0100
commitf0fd0fa275bf9552eb857ed38a80ba7589bd7ef2 (patch)
tree31519f5801a38b27b715ad8ecf93b45b538ef326 /dev-qt/qtwayland
parentnet-wireless/wpa_supplicant: bump bug #672568 (diff)
downloadgentoo-f0fd0fa275bf9552eb857ed38a80ba7589bd7ef2.tar.gz
gentoo-f0fd0fa275bf9552eb857ed38a80ba7589bd7ef2.tar.bz2
gentoo-f0fd0fa275bf9552eb857ed38a80ba7589bd7ef2.zip
dev-qt: Add Qt 5.11.3
Bug: https://bugs.gentoo.org/670864 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.11.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index eb48e459e534..77f068d19e7f 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,3 +1,4 @@
DIST qtwayland-everywhere-src-5.11.1.tar.xz 392200 BLAKE2B 2e65c6bd8c9ea44ae84f608312db6983d540382bfb2a22412fe054f4e7253d70e21f4d0577653b246de5b0266271e40911a7c79fc28b266cc29ff30669df280e SHA512 dc1327ef8cdc9ed9521e9db316da0bcdbe9639b714a2dda7a792c52ba5897ddb75deba1ab89e010bc05cc2a96ede781b9990f5449ce4a2f85e15466a4d6d82ad
DIST qtwayland-everywhere-src-5.11.2.tar.xz 387644 BLAKE2B e590d0f83e89a2ea33f4782cf295df4fe8ffc5e3767dbcb81ad633a2de35eda714e28a69a9c95263786883fff66a25ce5e9b52dab9929f499a0b8dab90489cc6 SHA512 27aabe18cf876afaf9da9e9fa91c3efa2c024229a6cf4746eefc4f4ea71f125a95ca52f887a42683d7743d3f876efe927001b8ee5580123ba5f4c4d4dea24013
+DIST qtwayland-everywhere-src-5.11.3.tar.xz 391124 BLAKE2B 2bc90c7a6f6769bcae7e52072d71f38ad984cc931767613e7972373131c9d58c145e9882c29163190257f07a205bdda63f78833859d2be6d6478126c301b70a1 SHA512 e442a13c61a508d6021fb15a0917b7861faf139fb7dca41ac1a3967f4b8dc82da5095029e4c6120464bd36ecf559547fe2f42935d9980f19298f5875cfb5e62e
DIST qtwayland-opensource-src-5.9.6.tar.xz 316152 BLAKE2B a1ebbf98eea9ca36f8229ed0bdfdeb79eb9d1519ff35eb153d7f8b7af2ad9831905e564464ec1faf793a7b11088d43d6dda6dc21b36943fccb569163c119a30a SHA512 7376f76001323d7971cb3be7592086b26c855d8d702184e84f28656b4262a9780b4cc0a0991c97ca011863570b6abd63b006c78021934e1516be65715f82ae4b
diff --git a/dev-qt/qtwayland/qtwayland-5.11.3.ebuild b/dev-qt/qtwayland/qtwayland-5.11.3.ebuild
new file mode 100644
index 000000000000..ff62f71d3a79
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.11.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput?]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}