summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-02-14 06:07:02 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-02-14 07:20:57 -0500
commit2311e7455112acc050d3bccdc0b50f4871ad4ce6 (patch)
tree6e8693fbe164bfc13070d3aa01430a81d84f8286 /dev-qt/qtscxml
parentdev-qt/qtquicktimeline: add 6.6.2 (diff)
downloadgentoo-2311e7455112acc050d3bccdc0b50f4871ad4ce6.tar.gz
gentoo-2311e7455112acc050d3bccdc0b50f4871ad4ce6.tar.bz2
gentoo-2311e7455112acc050d3bccdc0b50f4871ad4ce6.zip
dev-qt/qtscxml: add 6.6.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-6.6.2.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index 6cec2064f8ee..748e680d442a 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,2 +1,3 @@
DIST qtscxml-everywhere-opensource-src-5.15.12.tar.xz 437972 BLAKE2B 11bd9a22eada2927e98d7d22f8e17150f7e225b1036173cddd82859b84073dd547278c5df6f096a6318755aa853bc16d8ed2a9721282feedde9ff758b404d80c SHA512 c451fa8fc5999aa7e3b3a336503bcf1ccc8992ef27645d003c938166384508d2cc9b35fbd21e9da641ea98a2aaa58834ac85e8713bce25b96e4aef79c3cda976
DIST qtscxml-everywhere-src-6.6.1.tar.xz 1176684 BLAKE2B fa10e70b6500fe6ad2014ba4b82689881fcb7e7a0edc47b7db23d87c9eca26831cdb3d892665d6020069dad5c2287145560dd341be905076b8a9ac04cf88c503 SHA512 3c4b117138e9437a0e7b3f212e3a77aaf42c9fcbfdb30db0693e3fbf1562c68a88558951ff627dc9e91ff10625f3b269d115479e83cada46b9f9094f3d51e5a7
+DIST qtscxml-everywhere-src-6.6.2.tar.xz 1167628 BLAKE2B c1c32a815bf10eaa9b30241a3dbd6302d75131ef10f6ad2aeff10c0698fa82c937b1086e7f4f157c86659be0fa720d863b1723fbd119291ce549ebe5903e0ad6 SHA512 b7058d310dd82d09ca859dae5529d63bcde68a985a4c3f8f00474e2ffcd8f2f1162ffdafe3bb0cfc29769bc53ea4725dc8b68b04a09dcbea653d9afafca2643c
diff --git a/dev-qt/qtscxml/qtscxml-6.6.2.ebuild b/dev-qt/qtscxml/qtscxml-6.6.2.ebuild
new file mode 100644
index 000000000000..02fdb8a7936d
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-6.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt6 framework"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtbase-${PV}:6[gui]
+ qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
+"
+DEPEND="${RDEPEND}"
+
+CMAKE_SKIP_TESTS=(
+ # may fail with pid-sandbox, or at least musl/hardened+gcc (exact
+ # conditions unknown but passes without pid, considering this flaky)
+ tst_qstatemachine
+)
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package qml Qt6Qml)
+ )
+
+ qt6-build_src_configure
+}