summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-11-25 20:29:59 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-11-25 20:32:34 +1100
commit701402b1682e96af88c2e1d3ae42e8b88e308a1e (patch)
tree04f0eebe735f1b27150d4e87326af0f2b043666b /dev-qt/qtpositioning
parentsys-devel/heirloom-devtools: Really commit patch for fixing gcc6 support (#59... (diff)
downloadgentoo-701402b1682e96af88c2e1d3ae42e8b88e308a1e.tar.gz
gentoo-701402b1682e96af88c2e1d3ae42e8b88e308a1e.tar.bz2
gentoo-701402b1682e96af88c2e1d3ae42e8b88e308a1e.zip
dev-qt: version bump 5.9.3
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-qt/qtpositioning')
-rw-r--r--dev-qt/qtpositioning/Manifest5
-rw-r--r--dev-qt/qtpositioning/qtpositioning-5.9.3.ebuild37
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-qt/qtpositioning/Manifest b/dev-qt/qtpositioning/Manifest
index e35fa53d63c2..cc6298feaa92 100644
--- a/dev-qt/qtpositioning/Manifest
+++ b/dev-qt/qtpositioning/Manifest
@@ -1,2 +1,3 @@
-DIST qtlocation-opensource-src-5.7.1.tar.xz 3194112 SHA256 f9e9e64e757008c2341504a1916a219ee0cf2b1b42bfa72156e62dfe9dfbf39f SHA512 a3e0318ad348edd6d9cb4762d4fc6230a47984fcf526f55cc2c9bc00e2e70fdb1380866ec8906e3f58669c62464f8747c948d85107a2d30be1e98da27c7739d4 WHIRLPOOL be30847a33b1bb356d6725202968e189abf4a5bcdc5c2decf9a7ffc14b2d3875dfde827b41b97bf11c9497ec584f351c567150d84bb93fedeb3cb15ce0ac0075
-DIST qtlocation-opensource-src-5.9.2.tar.xz 5369548 SHA256 c81a42e44ebd4e9c33f7195e86af3deab9fde72ef0ad8dcb04acee250d356b0c SHA512 da2e011d37b1c30395360987d66978c842aae41491ce3201316ebe1acf453fb31626575e3c3d65836aa6ac80e3d4324a613f0245e90598b507a89d13ea241786 WHIRLPOOL 2a2dd20d9fc5ae75e469438587dd1d57b65a5a5e642a6806bc067b0cfa914ef0309a63b37163b0fb349134bb3b6a1fb4785691c1a8d2ef681c624df29a1df67a
+DIST qtlocation-opensource-src-5.7.1.tar.xz 3194112 BLAKE2B b5ac3bed420507c4a03b382c23d02cf0638c64e4921872930ec22394c3eaef7b7abaf7830d40c3aa2c9888e91724d5795b17a6d2a37f2f21b97285ef7d0dfd69 SHA512 a3e0318ad348edd6d9cb4762d4fc6230a47984fcf526f55cc2c9bc00e2e70fdb1380866ec8906e3f58669c62464f8747c948d85107a2d30be1e98da27c7739d4
+DIST qtlocation-opensource-src-5.9.2.tar.xz 5369548 BLAKE2B c7214e1b972c73020d6d90b605cd53bdb8ce5c0804176333366334b8fd012a78e885ba492df45cdd87815cd7f1fc8674c0ed34ede63b86a89f089f86685bffec SHA512 da2e011d37b1c30395360987d66978c842aae41491ce3201316ebe1acf453fb31626575e3c3d65836aa6ac80e3d4324a613f0245e90598b507a89d13ea241786
+DIST qtlocation-opensource-src-5.9.3.tar.xz 5374552 BLAKE2B d8f7449daf02d98b9ad3ccc93a547f6d0cbe25f4d17637f1efada9cf6d00e84a082845c16a488a6653570b33a2c3be9c8f2dfc6881cba5a10e35e1a96f23893a SHA512 11bf2c6000fc2db92dc857cc6f271e7ff19f500fde14520678e9af57fac41debde4c4b937dbab4fe1f7d5744e1bd0fc25ea32fceecf97d32cecdbbc8e2105373
diff --git a/dev-qt/qtpositioning/qtpositioning-5.9.3.ebuild b/dev-qt/qtpositioning/qtpositioning-5.9.3.ebuild
new file mode 100644
index 000000000000..ccf6ea6d6bc3
--- /dev/null
+++ b/dev-qt/qtpositioning/qtpositioning-5.9.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qtlocation"
+inherit qt5-build
+
+DESCRIPTION="Physical position determination library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~x86"
+fi
+
+IUSE="geoclue qml"
+
+RDEPEND="
+ ~dev-qt/qtcore-${PV}
+ geoclue? ( ~dev-qt/qtdbus-${PV} )
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+DEPEND="${RDEPEND}"
+PDEPEND="
+ geoclue? ( app-misc/geoclue:0 )
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/positioning
+ src/plugins/position/positionpoll
+)
+
+pkg_setup() {
+ use geoclue && QT5_TARGET_SUBDIRS+=(src/plugins/position/geoclue)
+ use qml && QT5_TARGET_SUBDIRS+=(src/imports/positioning)
+}