summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-11-01 12:58:56 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-11-01 13:00:56 +0100
commit2592a62f5b30a672e915879ac9134f68f20c5e38 (patch)
treec1fc25eafacb679fb6a12b556496ddb804e25a06 /dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild
parentmedia-sound/jack2-1.9.13: bump (diff)
downloadgentoo-2592a62f5b30a672e915879ac9134f68f20c5e38.tar.gz
gentoo-2592a62f5b30a672e915879ac9134f68f20c5e38.tar.bz2
gentoo-2592a62f5b30a672e915879ac9134f68f20c5e38.zip
dev-qt: Add Qt 5.13.2
Closes: https://bugs.gentoo.org/689016 Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild')
-rw-r--r--dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild b/dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild
new file mode 100644
index 000000000000..6f8451cd6b64
--- /dev/null
+++ b/dev-qt/qtbluetooth/qtbluetooth-5.13.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+QT5_MODULE="qtconnectivity"
+inherit qt5-build
+
+DESCRIPTION="Bluetooth support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+IUSE="qml"
+
+RDEPEND="
+ ~dev-qt/qtconcurrent-${PV}
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdbus-${PV}
+ >=net-wireless/bluez-5:=
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+DEPEND="${RDEPEND}
+ ~dev-qt/qtnetwork-${PV}
+"
+
+src_prepare() {
+ sed -i -e 's/nfc//' src/src.pro || die
+
+ qt_use_disable_mod qml quick src/src.pro
+
+ qt5-build_src_prepare
+}