summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-19 22:18:20 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-19 22:22:28 +0200
commitf21ce9b294121566ad04c1708171950e0956b550 (patch)
treea8bcc7ef03563ac5b226cedceb9ea548e4933599 /dev-python
parentsci-mathematics/why3-for-spark: Adding why3 for spark (diff)
downloadgentoo-f21ce9b294121566ad04c1708171950e0956b550.tar.gz
gentoo-f21ce9b294121566ad04c1708171950e0956b550.tar.bz2
gentoo-f21ce9b294121566ad04c1708171950e0956b550.zip
dev-python/pysha3: New package
Add the backport of SHA3 hash functions for Python < 3.6, it is the most lightweight provider of the hash for Portage.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pysha3/Manifest1
-rw-r--r--dev-python/pysha3/metadata.xml15
-rw-r--r--dev-python/pysha3/pysha3-1.0.2.ebuild22
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pysha3/Manifest b/dev-python/pysha3/Manifest
new file mode 100644
index 000000000000..50179c5f7d91
--- /dev/null
+++ b/dev-python/pysha3/Manifest
@@ -0,0 +1 @@
+DIST pysha3-1.0.2.tar.gz 829192 SHA256 fe988e73f2ce6d947220624f04d467faf05f1bbdbc64b0a201296bb3af92739e SHA512 57476d24b9d399471cf56c8c1413f58dbc863c16d4fe9ebd2cf65df8092e139e2505252605e3fccd68978f5ee3fffdfeeedee6788aab38a54c918a452fc19720 WHIRLPOOL 0de14913b4c02b1c8310432f6a71ed986c6f525c7b15bb6e91d3972a84f5599b13d621b04a4007ea276089cd75d965798a84b11d378e02ab50e1b6d243b62bc0
diff --git a/dev-python/pysha3/metadata.xml b/dev-python/pysha3/metadata.xml
new file mode 100644
index 000000000000..410617d33dce
--- /dev/null
+++ b/dev-python/pysha3/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tiran/pysha3</remote-id>
+ <remote-id type="pypi">pysha3</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pysha3/pysha3-1.0.2.ebuild b/dev-python/pysha3/pysha3-1.0.2.ebuild
new file mode 100644
index 000000000000..2f9172ea7855
--- /dev/null
+++ b/dev-python/pysha3/pysha3-1.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="SHA-3 (Keccak) for Python 2.7 - 3.5"
+HOMEPAGE="https://github.com/tiran/pysha3 https://pypi.python.org/pypi/pysha3"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="CC0-1.0 PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+}