summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-11 09:08:21 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-11 09:48:09 +0100
commitdb5c7243248009b08eaebc1d4674b3784ad04b40 (patch)
treeb19d8fe41744feb243be572979900b993c2fa43c /dev-python
parentdev-python/botocore: Bump to 1.20.25 (diff)
downloadgentoo-db5c7243248009b08eaebc1d4674b3784ad04b40.tar.gz
gentoo-db5c7243248009b08eaebc1d4674b3784ad04b40.tar.bz2
gentoo-db5c7243248009b08eaebc1d4674b3784ad04b40.zip
dev-python/boto3: Bump to 1.17.25
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.17.25.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 4f450429680a..0389f5cdff7e 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -8,4 +8,5 @@ DIST boto3-1.17.21.tar.gz 348371 BLAKE2B 97799d4013e8ace6ebdfbb471c51743112e0d10
DIST boto3-1.17.22.tar.gz 348457 BLAKE2B 952650e5ebd51fe8f83ab9eeb0b9d76438865205cae75ff52fcb51aef38f2a3b61a0838dc7dbecac13f71774619a55b944bf8afc5894c93016c37b283e19cab0 SHA512 02a0e9f7723d61b5d21cc503f5dd3001aeb9433b989688728d5475e40852e84dfb0de6757f38c78b40b47d81321236aaf535aaa0b763deac8df9e4c1213c87b4
DIST boto3-1.17.23.tar.gz 348518 BLAKE2B 53e918cbb39f4cc1a5fc9303817efe7fade551c0c6ff80ef4093871fe1c99a4e01bb9dbdf5815c4b46803a327878454971a88a8fa12053009a61afefacfe9b84 SHA512 f4e9ccfe4d7da3bec049f415e5236e00c701335b3eec842c2e6955e43b4b1ede834b116b6299f43c3cd6eae3d2496ffb58017b64730a3bc8c1913d603c9eadf9
DIST boto3-1.17.24.tar.gz 349323 BLAKE2B 41a15fb92218d9aa936300054805b4cda52f373165e6d9f1f0b9f1edc0035e95a1134a407dd740856f8d28878e77ea669e6589ca20ab7af616390fda575d661c SHA512 57bc612e1f86edd2264364ad35c4a334a0ed98173d4f1e6808dce0b3c65dda4eb550fa231520aa67259a185d37e2b9e61e5ab4e1d7c41f7a0f22f270d1a07867
+DIST boto3-1.17.25.tar.gz 349475 BLAKE2B 272c5bebed211d015638a652109f2b56475e0d682ff585915061a495ce26ca6c12a5e844f9d4b73fca105c2f40e3fe7c1aa5bee045af284f45e74899cde3fde2 SHA512 d24c118a4af747360f226c9c6e98e26ad3dacf34f13dadb084fef4e7404d1141c66cf5d7074eeea2c792b134e7b83174bc0be0c387c478fd61de646118b41b9e
DIST boto3-1.17.7.tar.gz 346682 BLAKE2B 08c06dda1d59b4f555cad075673917b38cbf9ad8d0037f66027b17076e60b4d5fd32a93e088635320ebc3226a9cd8809c9208ec84f8588c26a77766b21dbee98 SHA512 2ba1817575c4a64c232c84a75a9d3b0db1de8634ded9aa31844930a82ccf4611805c6dd31b2e4d36cc9a2cc1813d233b4d7366305eaf28efd46a3b843d3c2993
diff --git a/dev-python/boto3/boto3-1.17.25.ebuild b/dev-python/boto3/boto3-1.17.25.ebuild
new file mode 100644
index 000000000000..74b9170a9119
--- /dev/null
+++ b/dev-python/boto3/boto3-1.17.25.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="https://github.com/boto/boto3"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="https://github.com/boto/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # prevent an infinite loop
+ rm tests/functional/docs/test_smoke.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests -v tests/unit/ tests/functional/ || die "test failed under ${EPYTHON}"
+}