summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-29 20:58:15 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-29 21:06:54 +0300
commitcf0c8ea02673fc4cb251ffca3a0788b4c655e3ed (patch)
tree2278d56e99fcf9cca26f793f613f7550a050b1c7 /dev-python
parentdev-lang/php: Version bump for 8.1.11 (diff)
downloadgentoo-cf0c8ea02673fc4cb251ffca3a0788b4c655e3ed.tar.gz
gentoo-cf0c8ea02673fc4cb251ffca3a0788b4c655e3ed.tar.bz2
gentoo-cf0c8ea02673fc4cb251ffca3a0788b4c655e3ed.zip
dev-python/pytest-check: add 1.0.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-check/Manifest1
-rw-r--r--dev-python/pytest-check/pytest-check-1.0.10.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytest-check/Manifest b/dev-python/pytest-check/Manifest
index 93d46d343b7c..5f58b6890806 100644
--- a/dev-python/pytest-check/Manifest
+++ b/dev-python/pytest-check/Manifest
@@ -1 +1,2 @@
+DIST pytest-check-1.0.10.tar.gz 15603 BLAKE2B e51dbb2806bdac73e202b14668c76675979113f661eb339a1a3cff07069d3d4709869d67ea2cb6384483ebde8b68288026df9b7492b17ea67c79ee95e6865809 SHA512 dc3a80b20637eab8adda085ca8172bc3bde75bd47566972a07cf226bb38771933a531d99e139d7c220cc149715fd7d98ab964f72e0b520e8dd3df7633a6e5a90
DIST pytest-check-1.0.9.tar.gz 15260 BLAKE2B 8bbf0299e76a0e5acbb6ab4e8ce2bcb386ad2e1e91e1596e317bed9800b03c0fcadf76abe76a0ab9d2d8d190dbd839e042579abb08ea898b8325c27898670088 SHA512 058bb17255f08b83e0fc9f6c91be99b2a17676eae903f70999598c1ee69cf0b89cbe3767bbc3fabbacb2a5db35d26ed825599f401f693f4dc6195c02fac5c923
diff --git a/dev-python/pytest-check/pytest-check-1.0.10.ebuild b/dev-python/pytest-check/pytest-check-1.0.10.ebuild
new file mode 100644
index 000000000000..31947e866cc2
--- /dev/null
+++ b/dev-python/pytest-check/pytest-check-1.0.10.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin that allows multiple failures per test"
+HOMEPAGE="
+ https://github.com/okken/pytest-check/
+ https://pypi.org/project/pytest_check/
+"
+SRC_URI="mirror://pypi/${P::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Fix expecting result in case pytest throws deprecation warnings
+ sed -e '/fnmatch_lines/s/\* /\*/g' \
+ -e '/fnmatch_lines/s/ \*/\*/g' \
+ -i tests/test_check.py || die
+
+ distutils-r1_src_prepare
+}