summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-16 09:14:04 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-16 09:46:11 +0100
commitc05ded9f8a6c8f55bd2b89e9c4d486490becbf4b (patch)
tree5affd53b2184ebdc0ecde7c976de0b93cc5bdbcc /dev-python
parentdev-python/nuitka: Bump to 0.6.18.3 (diff)
downloadgentoo-c05ded9f8a6c8f55bd2b89e9c4d486490becbf4b.tar.gz
gentoo-c05ded9f8a6c8f55bd2b89e9c4d486490becbf4b.tar.bz2
gentoo-c05ded9f8a6c8f55bd2b89e9c4d486490becbf4b.zip
dev-python/rich: Bump to 10.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.16.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index bb9efa444564..9bcbe1a2a8e8 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -5,3 +5,4 @@ DIST rich-10.15.0.tar.gz 16279650 BLAKE2B c169ca3d9144349770a0baf56d6267d5ac2e85
DIST rich-10.15.1.tar.gz 16279572 BLAKE2B e91a9d168d88c1d8db4b0901809c4da29d32b2dd582b0a7584a2f20cc60ff4418a95e593c9085babb948c0ffb4568da3b752e60d36adfc85ee704d7dd4dfc7e7 SHA512 9544f00eaddbb69cb95a16a0cd780acff38a49cdc6e35217e88ed462333e17b295dc5fdd3bf1ae25ab5e9100804e1d055b0d81bd0bca805e7b433238313f2edd
DIST rich-10.15.2.tar.gz 16282858 BLAKE2B 7fe05eb357e5137319764b0d751c3bc68f8545e391575a9a360b252c395714ecb8ad7b944e7c77e74990413cb6bfb2a6c6db0fb8e72eb098f91c8d5d86bc9f8a SHA512 02e851cc9a72cb62d1826f82a5b8919a8911cf3dbdfe5f5443a89b2b7bc48c575dcf5ba63c17da60cf2ef9de3d036c7b68a845610be72af63d082d487c3b61c2
DIST rich-10.16.0.tar.gz 16280103 BLAKE2B af66398a4bc6e3e5503418721906679dc6f964b6dcbb56195f64d0ef4f504d9e0002f8b727c4fba7b42dda8790a03bb12a85150b99d5294712e38dea2800f841 SHA512 48c9e4d0b733cf79e9bceac284ca3cf37c14f52c0f3590f08acd9b0ea791da0200753f3cbae13a619b9c42fdb1167d55724c80123e2935bf2ed7133a15639ac8
+DIST rich-10.16.1.tar.gz 16280385 BLAKE2B dda2e6a64f9ecfe99fdda3a2e24c6a859e25eca48ebc2af63dbea3c8b90f977e10253721e85b876165c9f51c52ceed057e77b08cf2c77c28de67b8a2c49c4617 SHA512 341aa3fdb7fe608d15c867eb50f36fcc250e041a256e4bee86f0c69e7e0f9239c84be88833dad56f05edeb09a734d64f423b9080bd13b88c3a59d958e8ff1f4c
diff --git a/dev-python/rich/rich-10.16.1.ebuild b/dev-python/rich/rich-10.16.1.ebuild
new file mode 100644
index 000000000000..1b1b101a6a98
--- /dev/null
+++ b/dev-python/rich/rich-10.16.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -p no:pytest-qt
+}
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}