summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-23 15:35:31 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-07-23 15:49:07 +0200
commit93d03e99f4df4b98fc4c111b82175face649e966 (patch)
tree0172a59756c76358457285c9ec8fe78b0994a16a /dev-python
parentdev-python/requests: keyword 2.26.0 for ~riscv (diff)
downloadgentoo-93d03e99f4df4b98fc4c111b82175face649e966.tar.gz
gentoo-93d03e99f4df4b98fc4c111b82175face649e966.tar.bz2
gentoo-93d03e99f4df4b98fc4c111b82175face649e966.zip
dev-python/python-lsp-server: introduce all-plugins USE flag
Spyder requires all optional plugins for pylsp to be installed. Previously we handled this in the spyder ebuild. However, different versions of pylsp can be (in)compatible with different versions of these plugins. Which means that we run into problems with spyder if the version dependecny information for version X is recorded in the spyder ebuild, but version Y of pylsp is installed. The obvious solution is to record these dependencies in the pylsp ebuild instead, however to not pull in *everything* unconditionally we also introduce the USE flag. Package-Manager: Portage-3.0.20, Repoman-3.0.3 RepoMan-Options: --force Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-lsp-server/metadata.xml3
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.0.1-r1.ebuild (renamed from dev-python/python-lsp-server/python-lsp-server-1.0.1.ebuild)16
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.1.0-r1.ebuild (renamed from dev-python/python-lsp-server/python-lsp-server-1.1.0.ebuild)16
3 files changed, 33 insertions, 2 deletions
diff --git a/dev-python/python-lsp-server/metadata.xml b/dev-python/python-lsp-server/metadata.xml
index d18c2963a96b..bad826ef127c 100644
--- a/dev-python/python-lsp-server/metadata.xml
+++ b/dev-python/python-lsp-server/metadata.xml
@@ -13,4 +13,7 @@
<upstream>
<remote-id type="pypi">python-lsp-server</remote-id>
</upstream>
+ <use>
+ <flag name="all-plugins">Pull in all optional plugins</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.0.1.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.0.1-r1.ebuild
index 6acffdf397b9..664b3167fc9e 100644
--- a/dev-python/python-lsp-server/python-lsp-server-1.0.1.ebuild
+++ b/dev-python/python-lsp-server/python-lsp-server-1.0.1-r1.ebuild
@@ -16,6 +16,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
+IUSE="all-plugins"
+
BDEPEND="
test? (
dev-python/autopep8[${PYTHON_USEDEP}]
@@ -41,7 +43,19 @@ RDEPEND="
<dev-python/jedi-0.19.0[${PYTHON_USEDEP}]
>=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
dev-python/pluggy[${PYTHON_USEDEP}]
- >=dev-python/ujson-3[${PYTHON_USEDEP}]
+ all-plugins? (
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ >=dev-python/flake8-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ )
"
PATCHES=(
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.1.0.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.1.0-r1.ebuild
index 7bfbc16308b2..a81825d5a49e 100644
--- a/dev-python/python-lsp-server/python-lsp-server-1.1.0.ebuild
+++ b/dev-python/python-lsp-server/python-lsp-server-1.1.0-r1.ebuild
@@ -16,6 +16,8 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="all-plugins"
+
BDEPEND="
test? (
dev-python/autopep8[${PYTHON_USEDEP}]
@@ -41,7 +43,19 @@ RDEPEND="
<dev-python/jedi-0.19.0[${PYTHON_USEDEP}]
>=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
dev-python/pluggy[${PYTHON_USEDEP}]
- >=dev-python/ujson-3[${PYTHON_USEDEP}]
+ all-plugins? (
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ >=dev-python/flake8-3.8.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-0.10.5[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ )
"
distutils_enable_tests pytest