summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-12-15 21:17:56 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-12-15 21:18:06 +0200
commit85611ad28b102ac7c4c8ebac113b6fe913dda036 (patch)
tree7ce0db0d2b0415cb35c7e13f59ca55a61b4b67e6 /dev-python
parentdev-python/async_generator: treeclean (diff)
downloadgentoo-85611ad28b102ac7c4c8ebac113b6fe913dda036.tar.gz
gentoo-85611ad28b102ac7c4c8ebac113b6fe913dda036.tar.bz2
gentoo-85611ad28b102ac7c4c8ebac113b6fe913dda036.zip
dev-python/yamlpath: treeclean
Closes: https://bugs.gentoo.org/915986 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/yamlpath/Manifest1
-rw-r--r--dev-python/yamlpath/metadata.xml18
-rw-r--r--dev-python/yamlpath/yamlpath-3.8.0.ebuild54
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
deleted file mode 100644
index aed09cc84c7e..000000000000
--- a/dev-python/yamlpath/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST yamlpath-3.8.0.gh.tar.gz 227377 BLAKE2B 9a722a6f637144a8085c7b71c8ac0c966d2ff7eda7b7136614db06406024c21cdbf6b30d3a5cc7b78ba8e268d406c0db15f15130098b680a1ce36a6eb8d31b9c SHA512 8a91c1519a7a93b099c77d2f850dc775c0ca8147d3ea4eb96408bb3f53a102301c6a9b6d1c5c47580a59f701e8316ff49e27d4643c21c8bc87fb337e6982e91f
diff --git a/dev-python/yamlpath/metadata.xml b/dev-python/yamlpath/metadata.xml
deleted file mode 100644
index b4a77c52d5a4..000000000000
--- a/dev-python/yamlpath/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <upstream>
- <bugs-to>https://github.com/wwkimball/yamlpath/issues</bugs-to>
- <changelog>https://raw.githubusercontent.com/wwkimball/yamlpath/master/CHANGES</changelog>
- <doc>https://github.com/wwkimball/yamlpath/wiki</doc>
- <remote-id type="pypi">yamlpath</remote-id>
- <remote-id type="github">wwkimball/yamlpath</remote-id>
- </upstream>
- <maintainer type="person">
- <email>zmedico@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
-</pkgmetadata>
diff --git a/dev-python/yamlpath/yamlpath-3.8.0.ebuild b/dev-python/yamlpath/yamlpath-3.8.0.ebuild
deleted file mode 100644
index ad955b668138..000000000000
--- a/dev-python/yamlpath/yamlpath-3.8.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Command-line processors for YAML/JSON/Compatible data"
-HOMEPAGE="
- https://github.com/wwkimball/yamlpath/
- https://github.com/wwkimball/yamlpath/wiki
-"
-SRC_URI="
- https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RDEPEND="
- dev-python/ruamel-yaml[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -e '/ruamel\.yaml/d' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
-
- if ! has_version "dev-ruby/hiera-eyaml"; then
- EPYTEST_DESELECT+=(
- tests/test_commands_eyaml_rotate_keys.py
- tests/test_commands_yaml_merge.py::Test_commands_yaml_merge::test_yaml_syntax_error
- tests/test_commands_yaml_paths.py::Test_yaml_paths::test_search_encrypted_values
- )
- fi
-
- epytest
-}