summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-02-28 22:09:58 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-02-28 22:10:35 +0100
commit7f1895aa83849c913f7237033c925eac257aa5d3 (patch)
tree581fd044dbfd7a2165f6790fdf37abf50a503da2 /dev-python
parentnet-im/spectrum2: add log4cxx-1.0.0 support (diff)
downloadgentoo-7f1895aa83849c913f7237033c925eac257aa5d3.tar.gz
gentoo-7f1895aa83849c913f7237033c925eac257aa5d3.tar.bz2
gentoo-7f1895aa83849c913f7237033c925eac257aa5d3.zip
dev-python/django-crispy-forms: bump to 2.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django-crispy-forms/Manifest1
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild8
-rw-r--r--dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild27
3 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/django-crispy-forms/Manifest b/dev-python/django-crispy-forms/Manifest
index 8ccfa76bebff..52d7cbd7417f 100644
--- a/dev-python/django-crispy-forms/Manifest
+++ b/dev-python/django-crispy-forms/Manifest
@@ -1 +1,2 @@
DIST django-crispy-forms-1.14.0.gh.tar.gz 295826 BLAKE2B 4be78ba2eb8b7dfd6d9813d2a94b26ca571f3c8767f22e37e64deca517b0044d1684343f82790860f024b6eaf6759acfdb6975e4497e40bb75cc64ace3ce9745 SHA512 964ebcd74dd284d11cd0a820238468cce415a61b9ac83afe401b1414da0e27b3e9e0a9aa4fec411a8ff9fa08aa6fb56550c6262e0a9d821b17e12590fc06970c
+DIST django-crispy-forms-2.0.gh.tar.gz 273743 BLAKE2B 4169c4f77ddd0dd9f8786abd71ad762f645283555f250861f32b874fb9e189d4ca174285ee39b51bc5f0c0e8c2e83c2e00c34398c51ede65438a1c6b8a17c3ee SHA512 8b6f5b35cb90837b7cd6a64ed74afe6a19a80f287f66d0a139811990524e1a48d4d7c01e61fb7d303958522c47458d0aa0008a3d6c147f7d03dc790e53a80592
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
index 790ba770fa73..0463cb56afea 100644
--- a/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
+++ b/dev-python/django-crispy-forms/django-crispy-forms-1.14.0.ebuild
@@ -16,6 +16,12 @@ SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/${PV}.tar.gz
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="test" #Not working
+IUSE="test"
+RESTRICT="test" #Some tests are failing
RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
diff --git a/dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild b/dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild
new file mode 100644
index 000000000000..914ce0712232
--- /dev/null
+++ b/dev-python/django-crispy-forms/django-crispy-forms-2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="DRY Django forms"
+HOMEPAGE="https://github.com/django-crispy-forms/django-crispy-forms"
+SRC_URI="https://github.com/django-crispy-forms/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" #Missing crispy_bootstrap3
+
+RDEPEND="dev-python/django[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest