summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-03 23:28:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-03 23:29:45 +0100
commit63349c9d6b241791129e061f0c65b281966535ac (patch)
treeda2ac94c68ebbfed0f8333123be2284266ecf64a /dev-python
parentdev-python/ioflo: Remove old (diff)
downloadgentoo-63349c9d6b241791129e061f0c65b281966535ac.tar.gz
gentoo-63349c9d6b241791129e061f0c65b281966535ac.tar.bz2
gentoo-63349c9d6b241791129e061f0c65b281966535ac.zip
dev-python/numexpr: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/numexpr/Manifest2
-rw-r--r--dev-python/numexpr/metadata.xml4
-rw-r--r--dev-python/numexpr/numexpr-2.7.3.ebuild48
-rw-r--r--dev-python/numexpr/numexpr-2.8.0.ebuild30
4 files changed, 0 insertions, 84 deletions
diff --git a/dev-python/numexpr/Manifest b/dev-python/numexpr/Manifest
index f57f9f1f534b..8da6ec40ced0 100644
--- a/dev-python/numexpr/Manifest
+++ b/dev-python/numexpr/Manifest
@@ -1,3 +1 @@
-DIST numexpr-2.7.3.tar.gz 114113 BLAKE2B 95dca4fbd3148bbf198f82827a63fac3e9de29f677457f2ad45040e24a38bb05e4e09738efa0cac793970e18bdcd252e2744da96062217fd35b4054b10112989 SHA512 8234a65ce96ea0a2f20cce7dce3de652362a9edc86af2e7a333cdd8ecd87866f75970859ff39b04d529acc062b806cc8c64f262c318edd2897200d7e54b429e7
-DIST numexpr-2.8.0.tar.gz 111765 BLAKE2B 20b56ce6b5c83a72c317c1b03c1084f64a2438deaeaf73a97afc8ab75abe0d3aa3721df8e7921568ff14c36fc0737e87be82951d1911f2eedee8f0e9fcad2fb8 SHA512 33f54eed99cab552c868cc5091ea76e13da12367507161713304f48b322289a01aeabe750f13501cc5654c6068c7e6220c6adeb8703fef174a445860f142614f
DIST numexpr-2.8.1.tar.gz 111984 BLAKE2B b5d0b5bd5507c8c513db6404917b6256d9c8d232ea5d2f027f42cdac4a5e5c5f8c2db3d2283734f80d0ae7df2551314d088ccd2ed8e2c7401cc04a15ad61751d SHA512 243cddcb1fece9410e35c87a4c3f794ac0963ddfcc054b9a9c9842a2bb4e782d6c939f532d00d724d4b447d915764c3c8bbb87a99c71a22951798329aa7494bd
diff --git a/dev-python/numexpr/metadata.xml b/dev-python/numexpr/metadata.xml
index ca0038cd8456..347c251f2861 100644
--- a/dev-python/numexpr/metadata.xml
+++ b/dev-python/numexpr/metadata.xml
@@ -18,10 +18,6 @@
just-in-time (JIT) compiler, i.e. it does not require a compiler at
runtime.
</longdescription>
- <use>
- <flag name="mkl">Enable support for Intel Vector Math Library, part of
- <pkg>sci-libs/mkl</pkg>.</flag>
- </use>
<upstream>
<remote-id type="pypi">numexpr</remote-id>
<remote-id type="github">pydata/numexpr</remote-id>
diff --git a/dev-python/numexpr/numexpr-2.7.3.ebuild b/dev-python/numexpr/numexpr-2.7.3.ebuild
deleted file mode 100644
index 0f0886287f5b..000000000000
--- a/dev-python/numexpr/numexpr-2.7.3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~s390 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
- mkl? ( sci-libs/mkl )
-"
-
-python_prepare_all() {
- # TODO: mkl can be used but it fails for me
- # only works with mkl in tree. newer mkl will use pkgconfig
- if use mkl; then
- use amd64 && local ext="_lp64"
- cat > site.cfg <<- _EOF_ || die
- [mkl]
- library_dirs = ${MKLROOT}/lib/em64t
- include_dirs = ${MKLROOT}/include
- mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
- mkl_intel_thread, mkl_core, iomp5
- _EOF_
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys,numexpr; sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
- || die
- pushd >/dev/null || die
-}
diff --git a/dev-python/numexpr/numexpr-2.8.0.ebuild b/dev-python/numexpr/numexpr-2.8.0.ebuild
deleted file mode 100644
index 996ad208a7c7..000000000000
--- a/dev-python/numexpr/numexpr-2.8.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-
-DEPEND="
- >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
-"
-RDEPEND="${DEPEND}"
-
-python_test() {
- pushd "${BUILD_DIR}"/lib >/dev/null || die
- "${EPYTHON}" \
- -c "import sys,numexpr; sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
- || die
- pushd >/dev/null || die
-}