summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-09 08:27:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-09 09:38:04 +0100
commit5ecd56bd7367652a911d624820c4a77b86f72b1d (patch)
tree8dfbb7c6fdcd88d2afa1d399ba699984b8a5f0f3 /dev-python
parentapp-admin/awscli: Bump to 1.27.5 (diff)
downloadgentoo-5ecd56bd7367652a911d624820c4a77b86f72b1d.tar.gz
gentoo-5ecd56bd7367652a911d624820c4a77b86f72b1d.tar.bz2
gentoo-5ecd56bd7367652a911d624820c4a77b86f72b1d.zip
dev-python/sphobjinv: Bump to 2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphobjinv/Manifest1
-rw-r--r--dev-python/sphobjinv/sphobjinv-2.3.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/sphobjinv/Manifest b/dev-python/sphobjinv/Manifest
index 5af733c4cae2..d3bfb2dffd52 100644
--- a/dev-python/sphobjinv/Manifest
+++ b/dev-python/sphobjinv/Manifest
@@ -1 +1,2 @@
DIST sphobjinv-2.2.2.tar.gz 1188094 BLAKE2B f693254f3746b0e5cb6cc863be381f41d26465eab2e1494c29f30f1a72374e8d03dfa5c433958dfa1dcbaa0a7da1ff454c42da5c09011fa67264c26e3623a302 SHA512 36e7667b071f30d4ca066422b21d298c5691321d813ba6ad9eb7a69cd4107ceb18365ee2f95865fad64ab872428b035661a3f513df2e4aab1124b48f49c7280b
+DIST sphobjinv-2.3.gh.tar.gz 1342499 BLAKE2B e9871a9b15a74170e8208a40b128110959204bdac994566c19b6659b67198825dfab4d0ff8bad42bc8c88a17a7411c481f95b65f2d9c5925ec3c0e4b515aafad SHA512 ed4fc6a3ac4e06d3357d69a8b976394af6ef118ac87ccd8752413d18afc39b37e859656daf2eab6f27bfae4721a7a36db457c210cda5420159791e0b1db8fadd
diff --git a/dev-python/sphobjinv/sphobjinv-2.3.ebuild b/dev-python/sphobjinv/sphobjinv-2.3.ebuild
new file mode 100644
index 000000000000..4dcbce04a46a
--- /dev/null
+++ b/dev-python/sphobjinv/sphobjinv-2.3.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx objects.inv Inspection/Manipulation Tool"
+HOMEPAGE="
+ https://github.com/bskinn/sphobjinv/
+ https://pypi.org/project/sphobjinv/
+"
+SRC_URI="
+ https://github.com/bskinn/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/attrs-19.2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/fuzzywuzzy[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-3.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/dictdiffer[${PYTHON_USEDEP}]
+ dev-python/pytest-check[${PYTHON_USEDEP}]
+ dev-python/pytest-ordering[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ >=dev-python/stdio-mgr-1.0.1[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/timeout-decorator[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ README.rst::README.rst
+ tests/test_readme.py::test_readme_shell_cmds
+)
+
+src_prepare() {
+ sed -e '/CLI_TEST_TIMEOUT/s/2/20/' -i tests/test_cli.py || die
+
+ # remove bundled deps
+ rm -r src/sphobjinv/_vendored || die
+ sed -i -e 's:sphobjinv[.]_vendored[.]::' src/sphobjinv/*.py || die
+
+ distutils-r1_src_prepare
+}