summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-14 20:34:23 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-14 20:39:17 +0200
commit5b6b1a13efb27c1a2fddf2c8087786a3d83042c9 (patch)
treec3688baee854c2e009dd28f0ae14c9115dd13c35 /dev-python
parentdev-python/ensurepip-pip: New split package, v22.2.2 (diff)
downloadgentoo-5b6b1a13efb27c1a2fddf2c8087786a3d83042c9.tar.gz
gentoo-5b6b1a13efb27c1a2fddf2c8087786a3d83042c9.tar.bz2
gentoo-5b6b1a13efb27c1a2fddf2c8087786a3d83042c9.zip
dev-python/ensurepip-setuptools: New split package, v65.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ensurepip-setuptools/Manifest1
-rw-r--r--dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.0.ebuild27
-rw-r--r--dev-python/ensurepip-setuptools/metadata.xml11
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ensurepip-setuptools/Manifest b/dev-python/ensurepip-setuptools/Manifest
new file mode 100644
index 000000000000..74e325e1c68b
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/Manifest
@@ -0,0 +1 @@
+DIST setuptools-65.0.0-py3-none-any.whl 1217438 BLAKE2B 07e9bbc6c316edbd9f1110cfbd6203f3848ff406c88e0b7bf5fdd7454ca6ace467da6b34d47c126ecf19551504f9a40b4b47ac07509eeef2642b4408489fbe25 SHA512 ca73a8aee402175084461a8a20381ec1ab8885cb360eca3cad02b2d89da363786ff9a9c3406d8539bf1e20eac38ee1afad927ec4b7f2572decfff947f79bcacf
diff --git a/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.0.ebuild b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.0.ebuild
new file mode 100644
index 000000000000..96c75c915768
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/ensurepip-setuptools-65.0.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN=${PN#ensurepip-}
+WHL=${MY_PN}-${PV}-py3-none-any.whl
+
+DESCRIPTION="Shared setuptools wheel for ensurepip Python module"
+HOMEPAGE="https://pypi.org/project/setuptools/"
+SRC_URI="
+ https://files.pythonhosted.org/packages/py3/${MY_PN::1}/${MY_PN}/${WHL}
+"
+S=${DISTDIR}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ !<dev-python/ensurepip-wheels-100
+"
+
+src_install() {
+ insinto /usr/lib/python/ensurepip
+ doins "${WHL}"
+}
diff --git a/dev-python/ensurepip-setuptools/metadata.xml b/dev-python/ensurepip-setuptools/metadata.xml
new file mode 100644
index 000000000000..ac51c41b5f27
--- /dev/null
+++ b/dev-python/ensurepip-setuptools/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">setuptools</remote-id>
+ </upstream>
+</pkgmetadata>