summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-30 22:46:25 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-30 22:55:39 +0100
commit396580f0c09f3615775531bab823fe9c90e724ff (patch)
tree98c7f9ce5ddec87cc970bc62302924ae5b39a7a8 /dev-python
parentdev-python/mistune: Bump to 2.0.1 (diff)
downloadgentoo-396580f0c09f3615775531bab823fe9c90e724ff.tar.gz
gentoo-396580f0c09f3615775531bab823fe9c90e724ff.tar.bz2
gentoo-396580f0c09f3615775531bab823fe9c90e724ff.zip
dev-python/wcag-contrast-ratio: New dep of pygments, v0.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wcag-contrast-ratio/Manifest1
-rw-r--r--dev-python/wcag-contrast-ratio/metadata.xml13
-rw-r--r--dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/wcag-contrast-ratio/Manifest b/dev-python/wcag-contrast-ratio/Manifest
new file mode 100644
index 000000000000..64dc19f7685d
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/Manifest
@@ -0,0 +1 @@
+DIST wcag-contrast-ratio-0.9.gh.tar.gz 3347 BLAKE2B c32765e7011faf9128bd4c53673c4663b972e225e0f7249dd1b9f07b4184ae9ca93116f31de6a0538f04612a72ee1e805b37e1070ae62347508f29df2bbf9ec4 SHA512 70ff827b092cec884ba7e969deb8b5de944844b8d5536669f2c607061fbf569c217cec93268215deb9fdebc041efd992ed0cc89e0da013f9a1be8eeeb420cec5
diff --git a/dev-python/wcag-contrast-ratio/metadata.xml b/dev-python/wcag-contrast-ratio/metadata.xml
new file mode 100644
index 000000000000..6c547f086dfc
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">wcag-contrast-ratio</remote-id>
+ <remote-id type="github">gsnedders/wcag-contrast-ratio</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
new file mode 100644
index 000000000000..3fb295448138
--- /dev/null
+++ b/dev-python/wcag-contrast-ratio/wcag-contrast-ratio-0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A library for computing contrast ratios, as required by WCAG 2.0"
+HOMEPAGE="
+ https://github.com/gsnedders/wcag-contrast-ratio/
+ https://pypi.org/project/wcag-contrast-ratio/"
+SRC_URI="
+ https://github.com/gsnedders/wcag-contrast-ratio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}