summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-15 21:37:44 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-15 22:05:55 +0300
commit25d230c7b9fad074af369c702af008c1e416701d (patch)
tree3b3518916b2dcc5378aefe852243bf735f428ae3 /dev-python
parentdev-python/asttokens: add 2.0.8 (diff)
downloadgentoo-25d230c7b9fad074af369c702af008c1e416701d.tar.gz
gentoo-25d230c7b9fad074af369c702af008c1e416701d.tar.bz2
gentoo-25d230c7b9fad074af369c702af008c1e416701d.zip
dev-python/wand: add 0.6.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/wand/Manifest1
-rw-r--r--dev-python/wand/wand-0.6.10.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/wand/Manifest b/dev-python/wand/Manifest
index 6ff9c203df35..ed7e3205da28 100644
--- a/dev-python/wand/Manifest
+++ b/dev-python/wand/Manifest
@@ -1,3 +1,4 @@
+DIST Wand-0.6.10.tar.gz 11885159 BLAKE2B 206a652fa87a69f4d7af6156b2dc2b0ff515f317f9ad3d938ee15e50043ab3e3ffc052e0650ebfb2e5f5c5d1d1f1500f4880578a6cd7765d6c3af02f877fd843 SHA512 bde72e0ec56898c0885e483ec8dafc5dd2fbc1319736b5d46074cb00d1643c5368fbf66e0c8ff918dbe4b7b6ac4901551ee2c8563317c90c269e7ccfe53edf6f
DIST Wand-0.6.7.tar.gz 11686093 BLAKE2B 58abbdc22eb1603ed42e2e2473c0ed2b9026c9c0a499bb885512b56ecf01fb4ffe450979808bba2b4c4466994f86bea9a9c0ced216f8338c845b96a755f39c9f SHA512 e79ecb909f6ad7b3ddae217bb7b27f3c010d22a40eb99866e2a6eb07346000acbead280176e3352da13c20b68a341c751c55d6203bef7968522c8dbcfcab0b06
DIST Wand-0.6.8.tar.gz 11884527 BLAKE2B 45784abf55682d8b5e101cc4fc93f0492f9275a2805f06dbda2d98e28c6359c7df84fd7870b12348c0a6c513ae3f2bafba61a00020a41263d6a91fd67d9ce682 SHA512 111eef211edd8d5a6c825f0b455db5510c91b43852165934dbab36a9cdeea7e920987c98d975fb8c7f82ac19f20867c0ed5c8c1e2f9dd9467bc30931b4a03dd1
DIST Wand-0.6.9.tar.gz 11885077 BLAKE2B 15390e6aca4ac947dbeba84e2f6805689d4c44e318f7dd4827c6cf2cca42066968de0d9a7a932c950f79ef82bc090d8061e86b63234477f4807b5dc1cc36f735 SHA512 23adcb3360bc6a579aa4e4ff406631821cca05c8ad5ca057510a3185bf09ee58c13940706ce3b725545cc46ca5e8aaaebeb9b418e2a91cf15b570e223ede6552
diff --git a/dev-python/wand/wand-0.6.10.ebuild b/dev-python/wand/wand-0.6.10.ebuild
new file mode 100644
index 000000000000..d5709e974bca
--- /dev/null
+++ b/dev-python/wand/wand-0.6.10.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Ctypes-based simple ImageMagick binding for Python"
+HOMEPAGE="
+ https://docs.wand-py.org/
+ https://github.com/emcconville/wand/
+ https://pypi.org/project/Wand/
+"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ media-gfx/imagemagick
+"
+BDEPEND="
+ test? (
+ media-gfx/imagemagick[fftw,jpeg,png,truetype,xml]
+ )
+"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ # PDF support is blocked by the default ImageMagick security policy
+ epytest --skip-pdf
+}