summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-04 05:24:34 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-04 06:04:05 +0100
commit23a803be6cd673c111506d74189b64584d68c488 (patch)
treecd215666c4f13e253974693b3444bcdb1b2ddfd7 /dev-python
parentdev-python/simsimd: Remove old (diff)
downloadgentoo-23a803be6cd673c111506d74189b64584d68c488.tar.gz
gentoo-23a803be6cd673c111506d74189b64584d68c488.tar.bz2
gentoo-23a803be6cd673c111506d74189b64584d68c488.zip
dev-python/simsimd: Bump to 5.9.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/simsimd/Manifest1
-rw-r--r--dev-python/simsimd/simsimd-5.9.11.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/simsimd/Manifest b/dev-python/simsimd/Manifest
index 23adb28896e1..9eb681754609 100644
--- a/dev-python/simsimd/Manifest
+++ b/dev-python/simsimd/Manifest
@@ -1,2 +1,3 @@
DIST SimSIMD-5.8.0.gh.tar.gz 183559 BLAKE2B 2df0eac6eff58bc6c460b37cb7c523eae5d7e77d516bc7182ef3b39d033a1028d40536aaf99ad8ec8c28b4908ff873079ff0ca3d74acd1f763b0faaa5d4e225e SHA512 4e68050379dfe42e6c36a88a0defad0d941c873bda66cb4c65bd8367b07bca99a5c5d6eec7c8e39b15ad1b8e5bcc9dc7f43457d8552e9d72faefb88b03ad6f9b
DIST SimSIMD-5.9.10.gh.tar.gz 204187 BLAKE2B fdfdd6bb1473a60fd878a819f9d848bf90e9d35625c6112407e5af064d0b2ac80dedf3f7f0762dd40cc7bf2e79ddaee5baa8c708ff99ae98c8dfa9eb90853491 SHA512 7b4693d6513e01d486496ce46edf1a342d3f28e64b72f29bc6a0a8489e7be53056122d17b2dd9df297f3eb317260eff102aea7c49f90ca3a52485f289452f9cd
+DIST SimSIMD-5.9.11.gh.tar.gz 204255 BLAKE2B 6c67f47bf2beb41b8f6e091874c808a9be0da307d6bc7af5d6cca62435d1a4199cff7444b8b9f0ce04dbdd779641d635b8e7545512cfeb782ca81ef0f6e74e2e SHA512 eae6b0a509198de09a6d47c207554cc330ad1242b3a1d98d74d0fcb0c960052de1765e05d2bbe4bbb295224266dc393890a159b7fa933c6d7725685a5e50d1ec
diff --git a/dev-python/simsimd/simsimd-5.9.11.ebuild b/dev-python/simsimd/simsimd-5.9.11.ebuild
new file mode 100644
index 000000000000..3b7152ad7a71
--- /dev/null
+++ b/dev-python/simsimd/simsimd-5.9.11.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 toolchain-funcs
+
+MY_P=SimSIMD-${PV}
+DESCRIPTION="Fastest SIMD-Accelerated Vector Similarity Functions for x86 and Arm"
+HOMEPAGE="
+ https://github.com/ashvardanian/SimSIMD/
+ https://pypi.org/project/simsimd/
+"
+# no sdist, as of 4.3.1
+# https://github.com/ashvardanian/SimSIMD/issues/113
+SRC_URI="
+ https://github.com/ashvardanian/SimSIMD/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="openmp"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-repeat[${PYTHON_USEDEP}]
+ dev-python/tabulate[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
+ tc-check-openmp
+ fi
+}
+
+src_prepare() {
+ sed -i -e '/-O3/d' setup.py || die
+ if ! use openmp; then
+ sed -i -e '/-fopenmp/d' setup.py || die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p repeat scripts/test.py
+}